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Important
Please read this document carefully before using the SOFTWARE PRODUCT or assembling the HARDWARE
PRODUCT. By using the storage media or assembling the hardware, you are agreeing to be bound by the
terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sensors &
Software, Inc. at the address indicated at the end of this document.
Definition
The word PRODUCT as used herein defines any item sold by Sensors & Software, Inc. and may be
comprised of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which
means computer programs, codes and related support materials.
Software Product License Agreement
In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. does not
sell any rights to its Software products. Rather, Sensors & Software, Inc. I grants the right to use its
software, CDs, memory sticks (or other storage media) and documentation (hereafter collectively called
SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT license. You acknowledge and agree that
Sensors & Software, Inc. retains worldwide title and rights to all its software and that the SOFTWARE
PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws.
Grant of Software Product License
In consideration of payment of the license fee which is the price you pay for the SOFTWARE PRODUCT and
your agreement to abide by the terms and conditions of this License Agreement, Sensors & Software, Inc.
grants to you, the Licensee, a non-exclusive right to use the SOFTWARE PRODUCT under the following
conditions:
You may:


use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you;



copy the SOFTWARE PRODUCT for backup purposes in support of your use of the product on a single
workstation.

You may not:


copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials,
including modified or merged SOFTWARE PRODUCT to others;



sell, license, sublicense, assign or otherwise transfer this license to anyone without the prior written
consent of Sensors & Software, Inc.;



modify, adapt, translate, decompile, disassemble or create derivative works based on the
SOFTWARE PRODUCT.

Termination
This license is effective until terminated. You may terminate the license at any time by returning the
SOFTWARE PRODUCT and all copies to Sensors & Software, Inc. The license will automatically terminate
without notice by Sensors & Software, Inc. if you fail to comply with any terms or conditions of this
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agreement. Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to Sensors &
Software, Inc.
Update Policy
Sensors & Software, Inc. may create, from time to time, updated versions of its SOFTWARE PRODUCT. At
its option, Sensors & Software, Inc. will make such updates available to licensees who have paid the
update fee.
Product Warranty, Limited Remedy and Limited Liability
Sensors & Software, Inc. warrants the PRODUCT to be free from defect in material and workmanship under
normal use for a period of one year (365 days) from the date of shipment. Any third party computer
systems or other items not manufactured directly by Sensors & Software, Inc. purchased with any
PRODUCT or independently from Sensors & Software, Inc. are subject to the original manufacturer's
warranty and are not the responsibility of Sensors & Software, Inc.
Sensors & Software, Inc. makes no other warranties including, but not limited to, any implied warranty of
merchantability or fitness for a particular purpose. If this product is defective within the warranty period
stated above, your exclusive remedy shall be, at Sensors & Software, Inc.’s option to replace or repair the
Sensors & Software, Inc. product or refund the purchase price of the Sensors & Software, Inc. product.
Except where prohibited by law, Sensors & Software, Inc. will not be liable for any loss or damage arising
from this Sensors & Software, Inc. product, whether direct, indirect, special, incidental or consequential
regardless of the legal theory asserted.
All statements, technical information, and recommendations related to Sensors & Software, Inc. products
are based on information believed to be reliable, but the accuracy or completeness is not guaranteed.
Before using this product, you must evaluate it and determine if it is suitable for your intended application.
You assume all risks and liability associated with such use. Any statements related to the product, which
are not contained in Sensors & Software, Inc. current publications, or any contrary statements contained
on your purchase order shall have no force or effect unless expressly agreed upon, in writing, by an
authorized officer of Sensors & Software, Inc.
Sensors & Software, Inc. warrants the CD, memory stick or other storage media on which the SOFTWARE
PRODUCT is furnished to be free from defects in material and workmanship under normal use for a period
of ninety (90) days from the date of purchase as evidenced by a copy of your invoice.
Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either
expressed or implied, including, but not limited to, the use or result of use of the product in terms of
correctness, accuracy, reliability, currentness or otherwise. The entire risk as to the results and
performance of the PRODUCT is assumed by you. If the PRODUCT is defective or used improperly, you, and
not Sensors & Software, Inc. or its dealers, distributors, agents, or employees, assume the entire cost of
all necessary servicing, repair or correction.
Sensors & Software, Inc.'s entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at
Sensors & Software, Inc.'s option, either:


the replacement of any storage media (CD, memory stick etc.) or hardware components which do
not meet Sensors & Software, Inc.'s Limited Warranty and which are returned to Sensors &
Software, Inc. postage prepaid with a copy of the receipt, or



if Sensors & Software, Inc. is unable to deliver a replacement storage media which is free of
defects in material or workmanship, Licensee may terminate this agreement and have the license
fee refunded by returning all copies of the SOFTWARE PRODUCT postage prepaid with a copy of the
receipt.

If failure of any PRODUCT resulted from accident, abuse or misapplication, Sensors & Software, Inc. shall
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have no responsibility to replace the SOFTWARE PRODUCT, refund the license fee, or replace or repair the
HARDWARE PRODUCT.
Do not tamper with any PRODUCT. PRODUCT contains no user serviceable parts. If tampering is
evident in Sensors & Software, Inc.’s opinion, warranty is void and null.
No oral or written information or advice given by Sensors & Software, Inc., its dealers,
distributors, agents or employees shall create a warranty or in any way increase the scope of this
warranty and you may not rely on any such information or advice.
Neither Sensors & Software, Inc. nor anyone else who has been involved in the creation,
production or delivery of the PRODUCT shall be liable for any direct, indirect, special, exemplary,
incidental or consequential damages, claims or actions including lost information, lost profits, or other
damages arising out of the use or inability to use this PRODUCT even if Sensors & Software, Inc. has been
advised of the possibility of such damages.
This warranty gives you specific rights. You may have other rights which vary from province to province,
territory to territory and certain limitations contained in this limited warranty may not apply to you.
General
No right, license, or interest to any Sensors & Software, Inc. trademarks is granted hereunder with the
purchase of the PRODUCT or the SOFTWARE PRODUCT license.
Governing Law
In the event of any conflict between any provision in this license agreement and limited warranty and any
applicable provincial legislation, the applicable provincial legislation takes precedence over the
contravening provision. This agreement shall be governed and construed in accordance with the laws of
the Province of Ontario, Canada.
Serviceability
Should any term of this agreement be declared void or not enforceable by any court of competent
jurisdiction, the remaining terms shall remain in full effect.
Waiver
Failure of either party to enforce any of its rights in this agreement or take action against any other party
in the event of a breach of this agreement shall not be considered a waiver of the right to subsequent
enforcement of its rights or actions in the event of subsequent breaches by the other party.
Acknowledgement
You acknowledge that you have read this agreement, understand it and agree to be bound by its terms
and conditions. You further agree that this agreement is the complete and exclusive statement of
agreement between the parties and supersedes all proposals or prior agreements oral or written between
the parties relating to the subject matter of this agreement.
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Should you have any questions concerning this agreement, please contact:

Sensors & Software Inc.
1040 Stacey Court
Mississauga, Ontario
Canada L4W 2X8
Tel: (905) 624-8909
Toll Free: 1 800 267-6013
Fax:(905) 624-9365
E-mail: radar@sensoft.ca
Sensors & Software, Inc. trademarks are listed at: www.sensoft.ca/trademarks
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This product uses libkml, a google Inc. software library which is subject to the following conditions of use.
Copyright 2008, Google Inc. All rights reserved.
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.
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1 Introduction
EKKO_Project was designed to simplify the display, editing, processing, and
interpretation of Ground Penetrating Radar (GPR) data.
EKKO_Project increases productivity by giving you more time to view and interpret data
and less time spent organizing it.
Use EKKO_Project to display project (.gpz) files (compressed files containing GPR
linesets and grid data) intuitively in the Project Explorer tree. The Properties pane
displays GPR line details such as acquisition parameters and associated files.
The Line Preview window automatically displays the first line in the project with the view
settings from the data acquisition software or default view settings. The user can display
other lines by clicking on the line name in Project Explorer or using the arrow keys.
The MapView window displays the position of grids in the project space coordinate
system. If GPR data was collected with GPS or, if the relationship between the project
coordinate system and the global coordinate system (Latitude-Longitude or UTM) is
defined by the user, grids and the GPS path of GPR lines are displayed in MapView.
Depth slices processed in the field using the data acquisition software (LMX200) or
using the optional SliceView module (see below) are also displayed in the MapView
window.
The optional Processing module allows you to edit and process data, including cropping
data, time filters, migration and gain. You can then save processing streams as Recipes
that you can apply to other GPR projects.
GPR lines are visualized and the view settings edited using the optional LineView
module. See the LineView manual for more details.
The optional Interpretation module in LineView is used to create interpretations of
Points, Polylines, Boxes, and Annotations, view them in GPR lines, and then output your
interpretations as Reports. Point interpretations are displayed in MapView. See the
LineView manual for more details.
The optional SliceView module allows you to process and display GPR data collected in
a grid as a series of depth slices. Depth slices enhance interpretations at complex sites
by providing a powerful way of visualizing the spatial relationships between targets seen
in multiple GPR lines. SliceView also allows grid data to be exported in a 3D format.
See the SliceView manual for more details.
The optional Bridge Deck Condition Report module allows you to process point
interpretations on the rebar in a bridge deck or other concrete structure and output a
PDF report with an amplitude map image and statistics about the rebar in the structure.
The optional Pavement Structure Report module allows you to process polyline
interpretations on subsurface layers and output a PDF report with cross-sections of and
statistics about of the layers.
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2 Getting Started
EKKO_Project works with compressed GPR project files called GPZ (GPR Project Zip)
files. Each project file contains one or more GPR line data files and may contain
information from other related files such as GPS files that were saved as the GPR data
was collected.
New generation Sensors & Software GPR devices automatically create Project files
however, GPR data collected using older Sensors & Software GPR systems can easily
be added to a new EKKO_Project project file following the Creating a New Project
procedure.

2.1

Opening a Project

When you open EKKO_Project, the Getting Started dialog box automatically opens to
help you open or create a new project based on the data file format you select.

Figure 1: The Getting Started dialog box
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Open a Recent EKKO_Project File

1. In the Getting Started dialog box Open Existing Project pane, click the Recent
Projects drop-down list.
2. In the drop-down list, click the project file you want to open.

2.1.2

Open an Older EKKO_Project File

1. In the Getting Started dialog box Open Existing Project pane, click
2. In the Open dialog, navigate to the folder and select the project file you want to work
in.

Figure 2: Open Dialog

Only files with a .gpz extension are listed.
3. Select the project you want to work with and then click Open.
The project contents are displayed in the Project Explorer and, if positioning
information is available, the GPR lines are displayed in MapView.
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Creating a New Project

To create a new EKKO_Project file, in the Create a New Project pane, select one of the
following options:



A project file can contain multiple grids and line sets.

2.2.1

Adding a Grid

1. In the Getting Started dialog box Create a New Project pane, click
2. In the Open dialog box, navigate to and then select a grid (.gfp) file.

.

Only files with a .gfp extension are listed. For more details about GFP files, see Add
Grid.
3. Click Open.
The grid is displayed in the Project Explorer and indicated with the small green grid
on the folder.

2.2.2

Adding all Lines in Folder

1. In the Getting Started dialog box Create a New Project pane, click
.
2. In the Select folder to import lines from dialog box, navigate to and then select a
folder containing GPR lines.
3. Click Select Folder.
The new project folders will be displayed in the Project Explorer

2.2.3

Adding Line(s)

1. Click
.
2. In the Open dialog box, navigate to and then select one or more GPR (.hd) Lines.
Only GPR files with an .hd extension are listed.
Note: although only .hd files are listed and selected, the folder must also contain the
associated .dt1 file(s).
3. Click Open. The Line(s) are displayed in the Project Explorer
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3 EKKO_Project Interface
When a project file is open, EKKO_Project is populated with information about the GPR
data in the Project file.
Menu Bar

Project Explorer

Toolbars

Line Preview
Properties Tabs
MapView

Layer View
Figure 3: The EKKO_Project interface

The main EKKO_Project window consists of a Menu Bar, Toolbars, Project Explorer,
Line Preview, MapView, Layer View, and Properties tabs.
All windows can be moved, resized, and modified. The tabs that make up the Properties
window can be separated into individual windows (to learn more, see Window
Operations).

3.1

Active Window

EKKO_Project typically displays several windows at a time including Line Preview,
MapView and Project Explorer. Only one window can be active and accept changes at a
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time. The active window is the one that was last selected by clicking in it with the mouse
cursor and is usually identified by its darker title banner.
To make changes in a particular window, first ensure it is the active window.
Often, trying to edit a window immediately makes it the active window, for example,
selecting a GPR line in the Project Explorer by clicking on it or checking a layer in the
Layer window.
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Project Explorer

Project, folders, and files are displayed in the Project Explorer which is similar to
Windows Explorer. In Project Explorer, grids and linesets are used just like folders in
Windows, and GPR lines are similar to files.
To display all GPR Lines associated with a project folder, click the plus sign (+) beside
the grid or lineset name
Project Explorer
Toolbar

Pin window to frame
Lineset name

GPR Line icon

Selected GPR line

Attachment icon
i = Interpretations

t = Topography
g = GPS

p = Processing

Grid Name

Figure 4: Project Explorer pane displaying open data folders listing the GPR lines.

The names of all the GPR data files in the grid and/or linesets are listed. The line icon (
) indicates which files are GPR lines. If other files associated with the line (photos,
videos, field notes, etc.) have been attached, the line icon displays a paperclip icon
(to learn more, see Attach a File).

9

EKKO_Project User’s Guide

3.2.1

EKKO_Project Interface

Data Collections Linesets vs. Grids

Data collections in EKKO_Project are composed of either linesets or grids.
Grids are, by definition, a complete collection of GPR lines related to one another
spatially; GPR lines cannot be added or deleted from a grid (this requires a separate
utility program called GFP_Edit). However, individual GPR lines in a grid can be copied
and added to a lineset.
Linesets are collections of GPR lines that may or may not relate to one another
spatially. Linesets can be edited to add or delete GPR lines. GPR lines in linesets can
also be cut and/or copied and pasted into other linesets.

3.2.2

Selecting vs. Checking GPR Lines

GPR lines, linesets, grids, and projects can be selected in two different ways:

3.2.2.1

Clicking the Item Name

To select the name of a GPR line, lineset, grid, or project, click the item name.
Once an item is selected, it is highlighted blue and you can only apply Right Click menu
operations to the item.

If the item displayed in MapView, it turns red to indicate it has been selected. For
example, if a single GPR line collected with GPS is selected, the GPS path in MapView
turns red. If a grid is selected, all the grid lines turn red.
When a GPR line is selected in Project Explorer, either a line collected GPS or a grid
line, it is displayed in the Line Preview window.

Selected Line

3.2.2.2

Clicking the Item Checkbox

To access copy, cut, paste, delete, and process operations from the Standard Toolbar or
the Edit Menu, click the checkbox beside the GPR Line, lineset, grid, or project name.

10

EKKO_Project User’s Guide

EKKO_Project Interface

Note: When a GPR Line is checked, the GPR collection (lineset or grid) and the
project name are also checked. This feature enables you to identify when GPR Lines
in the collection are checked even if the GPR collection is collapsed (click the minus
sign [-]).

3.2.3

Associated Data Files

An icon is displayed next to the line name in Project Explorer to indicate whether any of
the following file types are attached to the GPR line:

3.2.3.1

GPS

If a GPS is connected to the GPR system during data collection, GPS files with the same
name as the GPR line are saved to the Project file and/or data folder. When the GPR
data is opened in EKKO_Project, GPS positions are automatically integrated with the
GPR lines. This is indicated by the letter “g,” see the example in the Project Explorer.
GPS integration means Latitude-Longitude and UTM coordinates are displayed on the
Status Bar when viewing the GPR line in LineView and listed in Reports.
The name of the GPS file is listed under the Attachments tab.

3.2.3.2

Topography

When a topography (.top) file with elevation information is attached to a GPR line, it is
indicated by the letter “t,” see the example in the Project Explorer.
Integrating topography information means that the GPR line can be plotted with an
elevation axis in LineView, rather than the default depth axis. Elevations of
interpretations and fiducial markers are also listed in Reports.
The topography file name is listed in the Attachments tab.
Topography files with the same name and in the same folder as the GPR line are
automatically attached. Topography files with a different name can be manually
attached; see the Attachments tab.
GPS files also contain elevation information; see GPS Files for more information about
GPS elevations and how EKKO_Project decides whether to use Topography file or GPS
file elevations.

3.2.3.3

Interpretations

Interpretations added to the file using the optional Interpretation module in LineView are
identified by the letter “i,” see the example in the Project Explorer. Interpretations are
points of interest (points, polylines, boxes, and annotations) added to GPR lines. This is
similar to adding a flag/fiducial during data collection.

3.2.3.4

Processing

GPR data that has been processed using the optional Processing module is identified by
the letter “p,” see the example in the Project Explorer.
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Project Explorer Toolbar

The Project Explorer toolbar displays four icons representing features that enable you to
add GPR lines to the current project.

3.3.1

Add a New Lineset

1. To add a new lineset folder to the current project file, in the menu bar click
A

.

folder opens in the Project Explorer.

2. To rename the new lineset, right-click New Lineset.
3. In the drop-down list, click Rename.

3.3.2

Add a Grid

1. To add a grid (.gfp) file to the current project, in the menu bar click
.
2. In the Open dialog box, navigate to the folder and click the grid file you want to open.
Only files with a .gfp extension are listed.
3. Click Open.
The new grid is displayed in the Project Explorer:

3.3.3

Add Lines to Lineset

1. To add lines to the selected lineset, in the menu bar, click
.
2. In the Open File dialog box, navigate the file folder and then select one or more
GPR (.hd) Lines.
The GPR lines are added to the current Lineset. If the highlighted item is not
contained in a lineset, a new lineset will be created in the project.
Note: GPR lines cannot be added to a grid.
3. Click Open.
The lines are displayed in the Project Explorer:

3.3.4

Attach a File

The Attach File feature enables you to attach any file to the selected GPR line, lineset,
grid, or project.
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Note: any item with the same name as the line is automatically attached when the
line is added to the project (for example, a picture of the site could be renamed as
LineX0.jpg so it is automatically attached to the project when the LineX0 data is
added).
1. To add an attachment to a file, in the menu bar click Attach File
.
2. In the Open File dialog box, navigate to the folder and then select the file you want
to attach.
3. Click Open.
The files are displayed in the Attachments pane:

Note: if you attach multiple topography (.top) or GPS (.gps or .gp2) files, the last file
attached is the one that is used.

3.3.5

LineView Module (Optional)

Double-clicking on a GPR Line name in Project Explorer displays it in the optional
LineView module. For more details, see LineView.

3.3.6

SliceView Module (Optional)

Double-clicking on a GPR grid name in Project Explorer displays it in the optional
SliceView module. For more details, see SliceView.

3.3.7

Right Click Menu

When you right-click a grid, lineset, or GPR line in Project Explorer, a context-sensitive
menu opens.
Tools in the right-click menu operate only on the item that was selected. The checked
items in the Project Explorer are ignored.
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Use the following table as a guide to working with the LineView Right Click menu
features:
Field
LineView

Description
Click
LineView to open and display project GPR lines in the optional
LineView module.
To learn more, see the LineView User’s Guide.

SliceView

With a Grid selected in the Project Explorer, click
SliceView to
open and display the grid as a series of depth slices in the optional
SliceView module.
To learn more, see the SliceView User’s Guide.

Rename

To change the name of the selected project, grids, or linesets, click
Rename.
Rename an item when you want to give the data a more descriptive
name.
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Field
Edit Flags/Fiducials

Description
To edit flags/fiducials added during data collection, click Edit
Flags/Fiducials. This opens a dialog listing all the fiducials in the
selected GPR line and allows the position and/or the text to be edited.

Note that the all original positions and comments are always available
by clicking on the Reset button.
Add Grid

To add a grid to the current project file, click

Add Grid.

You can only add files that have a .GFP extension.
Add Lineset

1 To add a lineset to the current project file, click Add Grid
To add a grid to the current project file, click Edit > Add Grid.
2 In the Open dialog box, navigate to and then click the grid (.gfp) file
you want to add.
3 Click Open.
The project file grid name defaults to the same name as the .gfp file.
To learn about renaming files, see Rename.

New Lineset

To add a new lineset folder to the current project file, click
Lineset.

New

A new folder named “New Lineset” appears in the Project Explorer list.
Add Line(s) to
Lineset
Attach File

To add one or more GPR Lines to a Lineset folder, click
Line(s) to Lineset.

Add

To attach any file to the currently selected GPR data line, lineset, grid,
or project, click

Attach File.

The file is then displayed in the Attachments tab.
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Field
Export Line

Description
Use the Export feature to send linesets, grids, or GPR Lines from a
project (GPZ) file to a different folder.
Exported files can be GPR data files (DT1 and HD) or other associated
files such as GPS and elevation (TOP) files.

Zoom To

Zoom to the currently selected GPR line or grid in MapView. The GPR
line or grid must be plotted in MapView so only grid lines or lines with
GPS are eligible or this option is greyed out and not accessible.

Position
Relationship

Modify the position of the selected grid or the project. If a grid is
selected, the grid-to-project position relationship is edited (see Grid
Wizard) – useful for moving a grid in the project coordinate system.
If the whole project is selected, the project-to-global position relationship
is defined or edited (see Project to Global).
Note: the position of Linesets, individual GPR lines or individual grid
lines cannot be edited with this option; the options are greyed out and
not accessible.

Process

To open the Processing dialog box, click

Process.

This feature enables you to edit and process selected GPR line using
repositioning, temporal and spatial filters, and migration features.
Undo Process

To reset the selected GPR line to its original format before processing
was applied, click

Undo Process.

Copied GPR lines are reset to the any processing they had at the point
they were copied.
When processing is undone to an item, the small letter “p” beside the file
name indicating that it was a processed file disappears.
Cut

Use the
Cut feature to remove the selected GPR line, lineset or grid
from the project.
This enables you to remove a GPR line from a lineset and paste it into a
different lineset.
Note: a GPR line cannot be cut from a grid.

Copy

Use the



Copy feature to:

Copy the selected GPR line so it can be pasted into the same or a
different lineset in the project
Copy the selected lineset or grid so it can be pasted back into the
project

Note: You can copy GPR lines from a grid and paste then into a lineset,
but you cannot be paste them into a grid.
Paste

Use the

Paste feature to:

Paste a copied or cut GPR line into the same or a different lineset
in the project
 Paste a copied or cut lineset or grid back into the project
Note: You can copy GPR lines from a grid and paste them into a lineset,
but you cannot paste them into a grid.
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Field
Delete

Description
To Delete the selected grid or lineset from a project, click

Delete.

You can also delete a GPR line from the Lineset in the project.
Note: GPR lines cannot be deleted from a grid. .
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Line Preview

The Line Preview window displays the GPR line currently selected in Project Explorer.
When EKKO_Project first opens, Line Preview automatically displays the first GPR line
listed in the project.
The user can change the Line Preview display to another GPR line in the project by:
1) Clicking on the name in Project Explorer, or
2) After clicking in the Project Explorer window to make it the Active Window, using
the up and down arrow keys on the keyboard to move to a new GPR line name.
Both options provide fast switching between lines to quickly review all the lines in a
project.
Any Flags/Fiducials added to the GPR line during data collection or interpretations
added to the GPR line using the optional Interpretation module are visible in the Line
Preview plot.
On the bottom of the GPR line is a simple legend listing the file path and line name, the
velocity used to calculate the depth axis and the View Settings (gain and filter).
After selecting the Line Preview window, use the zoom options to zoom in, out or to a
user-specified zoom window using the buttons on the View Control Toolbar or the View
> Zoom menu options.
After zooming in, plot the whole GPR line to the Line Preview window by selecting the
Fit to Window button on the View Control Toolbar or the View > Zoom menu option.
GPR lines plotted in Line Preview use the View Settings (gain, color table, filter, etc.)
from the Digital Video Logger. If these are not available, default settings that include
Auto gain, the “Bone” color palette and no background subtraction filter applied.
The View Settings can be changed in Line Preview by plotting the GPR line(s) in the
optional LineView module and changing the View Settings there. After exiting LineView,
the Line Preview settings for that GPR line are updated.
If LineView module is not enabled, change the View Settings for the GPR line on the
DVL and transfer the data, along with the new View Settings, to the PC and open the
updated project file in EKKO_Project.
Line Preview will not plot GPR traces in wiggle mode and GPR lines cannot be plotted
with an elevation axis with the traces shifted for topography – these advanced display
options are available in the LineView module.
If the Line Preview window is closed, open it by selecting Window > Open Line
Preview.
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MapView

The MapView window shows a plan map image of GPR lines and grids including
flags/fiducials, point interpretations and depth slices.
GPR lines are only displayed in MapView if they have some local coordinate (XY)
definition (i.e. part of a grid). MapView displays GPR lines in a grid as black lines with
arrows. Move the mouse cursor over the MapView image to display the XY coordinates
in the Status Bar along the bottom of the EKKO_Project screen.
If a grid or the GPR line was collected using with GPS, the GPS paths are also displayed
as dark green lines. Due to the variable accuracy of GPS units, the GPS lines will not
typically correspond exactly with the GPR lines.
Move the mouse cursor over MapView image to display the global position in LatitudeLongitude and UTM in the Status Bar along the bottom of the EKKO_Project screen.
The GPS paths will be displayed for any GPR line (part of a grid or not) that has GPS
data associated with it.

Compass

Project
Y Axis

Selected
Line

Interpretations

Flags/Fiducials

Project
X Axis

Figure 5: MapView Window
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If the GPR project does not contain any grids and none of the GPR lines were
collected with GPS, then the MapView window will remain greyed out as there is
nothing to plot.



When one or more GPR lines are selected in the Project Explorer, they appear in red
in MapView. If the file has an associated GPS file, the GPS path also appears in red.



Flags/Fiducials always appear as red diamonds with text nearby.



Point interpretations appear in the color and shape they were defined with.



Depth slices can be plotted in MapView. For more information, see below.

A compass icon
pointing to geographic North is displayed if the World-Project
relationship is defined. This relationship is calculated automatically if the GPR data were
collected with GPS. If this relationship is not defined, the Status Bar displays “GPS
relationship not defined”.
Use the following table as a guide to working with MapView:
Item

Description

Cross-hair position

As you move the cursor over an area in the Grid Map, the position of
the mouse cross-hair is displayed in XY coordinates and GPS (if
present) at the bottom right of the screen.

Flags/Fiducials

Flags/Fiducials are markers added during data collection at specific
trace positions along the line. Flags/Fiducials can be repositioned and
the labels edited (see Right Click Menu).

Interpretations

Interpretations added to the file using the optional Interpretation module
in LineView.
Interpretations represent points of interest (points, polylines, boxes,
and annotations) added to the line. To learn more, see Interpretations,
Only point interpretations are displayed in MapView.

Field Interpretations

Some GPR systems such as the LMX200 have the capability of adding
point interpretations in the field. These are just like the interpretations
added with the Interpretation module and are displayed in MapView.

Selected Line

The line selected in the Project Explorer is highlighted red in the plan
Map. The details of the selected line are displayed in the Properties
Pane.
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Depth Slices in MapView

Depth slices from grid data, generated with the optional SliceView module or, for some
GPR systems (for example, the LMX200), in the field with the data acquisition program
are displayed in MapView.

Slider bar

Depth Slice at 85 cm displayed in MapView.

Use the depth slice slider bar to scroll through the depth slices. You can also use the
mouse-wheel to smoothly scroll through the depth slices, after selecting the MapView
window to make it the Active Window.
The current slice depth is displayed next to the slider bar and in the window title.
For multiple grids, slice through all of them simultaneously, even if:




they are at different angles to one another,
they were collected with different GPR systems with different center antenna
frequencies
they were collected with different depth slice processing (slice thickness,
amplitude equalization gain, background subtraction filter, resolution, etc.).

For example, if depth slices were processed using a different slice thickness value, the
depth slices shown in MapView are the depth slices closest to the current depth value.
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Displaying Multiple Grids with GPS

Many GPR surveys are made up of multiple grids. EKKO_Project can display more than
one grid to confirm targets within the grids.
Multiple grids collected using GPS are automatically arranged within the MapView
window.
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Repositioning Grids

Multiple grids collected without GPS all have their X=0, Y=0 corner corresponding with
the X=0, Y=0 of the Project coordinate system, thus all the grids are “stacked” at that
position.

To move a grid within the project coordinate system, select the grid in Project Explorer
and then:
1) right-click to open the menu and select Position Relationship > Wizard or,
2) select Tools > Grid Position Relationship > Wizard
and follow the directions (see Grid Position Wizard).
For example, the image below shows grids after each one was repositioned within the
Project coordinate system.
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Editing and Merging Multiple Grids

Use the GFP_Edit utility program to edit grids or merge multiple grids to create one large
grid.
The key advantage of using GFP_Edit to merge multiple grids together is that then all
grid data are processed together in SliceView, so filters such as Background Subtraction
use all the data in their calculations.
Merging grids in GFP_Edit requires the grid lines for all grids to be parallel or orthogonal
(90 degrees) to one another. You cannot merge grids if grid lines are oriented at other
angles, for example, 45 degrees.
As well, all the grids being merged together must have consistent settings such as
antenna frequency, temporal sampling interval, antenna separation, etc. If any key
settings differ between grids, they cannot be merged together. In this case where there
are differences, it is better to plot the grids separately as shown in the sections above.
The GFP_Edit program does NOT read project (.gpz) files so, to use GFP_Edit to work
with grids inside a project file, all the grid lines must first be exported into “Line Data”
format (see Line Data).
Once grid editing and/or merging are complete in GFP_Edit, open the new grid in
EKKO_Project by importing the new grid (.gfp) file (Add a Grid).
To learn more, see the GFP_Edit User’s Guide.
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Layer View

The Layer View window allows the user to specify which items to display in MapView
and Line Preview windows.

All instances of unchecked items are removed from MapView and Line Proview; it is not
possible to specify particular items to remove, for example, GPS for a single line.
Description

Layer
Slice

Plot depth slices in the MapView window. Depth slices generated with
the optional SliceView module or, for some GPR systems, in the field
with the data acquisition program. For example the LMX200 generates
depth slices in the field.
For Conquest users, the PDC image is always plotted on top of depth
slices so ensure it is not selected when viewing depth slices.

PCD Slice

Plot Power Cable Detector (PCD) image in the MapView window. Only
available for grid data collected with a Conquest GPR system.
The PDC image is always plotted on top of depth slices so ensure it is
not selected when viewing depth slices.

Lines

Plot GPR grid lines in the MapView window. Grid lines plot on top of
depth slices so turning the grid lines off makes the depth slices more
visible.

GPS

GPS paths for lines and grids collected with a GPS in the MapView
window.

Flags/Fiducials

Markers added to GPR lines in the field during data collection.
When selected, Flags/Fiducials are displayed in both the Line Preview
and MapView windows.
Flags/Fiducials are indicated by a red diamond icon and a label such
as F1, F2 etc.
Flags/Fiducials can be repositioned and the labels edited (see Right
Click Menu).

25

EKKO_Project User’s Guide

Interpretations

EKKO_Project Interface

Interpretations added to GPR lines in the project using the optional
Interpretation module in LineView.
Interpretations are points of interest (points, polylines, boxes, and
annotations) added to GPR lines.
Some GPR systems such as the LMX200 have the capability of
adding point interpretations in the field. These are just like the
interpretations added with the Interpretation module.
All interpretations are displayed in Line Preview but only point
interpretations are displayed in MapView.

3.7

Properties Tabs

The Properties pane is a series of tabs that display information about the selected GPR
line. The Properties pane can usually be found on the right side of the EKKO_Project
screen; the tabs are displayed at the bottom of the pane.

3.7.1

Acquisition Tab

The Acquisition tab displays information about how the GPR line was acquired. It lists
the survey parameters under four headings: General, Positioning, Advanced, and
Additional Info. You may need to click the plus (+) sign to view the details under a
heading.
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To quickly open or close all the headings, click

.

Use the following tables to guide you through working with the Acquisition tab.
The General pane displays the following basic survey parameters:
Field

Description

Original Line Name

The name of the GPR line when first opened in EKKO_Project.

Comment

Comment about the system used to acquire the data.

Date Collected

The collection date.

Survey Type

GPR survey type: reflection, CMP/WARR, or transillumination.

Frequency (MHz)

The antenna center frequency

Time Window (ns)

The length of the time window in nanoseconds (ns).
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The Positioning pane displays the following parameters related to the positioning of the
GPR line:
Field

Description

Units

Meters or feet

Start Position

The initial position of the GPR system along the line, generally will be
zero, but could be different if an offset was used, or if the line was
collected as part of a forward/reverse grid.

End Position

The ending position of the GPR system along the line

Step Size

The distance interval along the surface between GPR data traces

Odometer Cal.

The calibration value of the odometer wheel (if applicable)

The Advanced pane displays the following advanced survey parameters:
Field

Description

Number of Traces

Total number of traces

Points per Trace

The number of sample points per trace

Antenna Separation

Spacing between transmitting and receiving antennas

Stacking Type






DynaQ ON: indicates automatic stacking
P: number of point stacks
S: number of trace stacks
A: maximum number of stacks

Stacks

Number of repeated measurements averaged to get resulting
measurements

Time Sample Interval
(ps)

The time period in picoseconds at which the GPR signal is sampled.
Often set automatically by the system based on GPR frequency.

First Break Offset (ns)

The number of nanoseconds from the start of the trace to the first
break

Transmitter Voltage

The voltage of the transmitter

Pulse Width (ns)

The width of the GPR pulse in nanoseconds. Varies with antenna
center frequency.

GPS Latency (s)

The GPS latency in seconds (only listed if a non-zero value applied)

GPS X Offset

X direction offset between GPR and GPS (only listed if non-zero value
applied)

GPS Y Offset

Y direction offset between GPR and GPS (only listed if non-zero value
applied)

GPS Z Offset

Z direction offset between GPR and GPS (only listed if non-zero value
applied)
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The Additional Information pane may include the serial numbers of the GPR system
and the Digital Video Logger (DVL), as well as any processing done prior to importing
the data.

3.7.2

Attachments Tab

The Attachment tab lists all files attached to the current GPR line, project, grid, or lineset
such as GPS files, topography files, photos of the line location, documents, videos of the
area, or voice recordings of information relevant to the GPR line.
Toolbar

3.7.2.1

Attachments Toolbar

Use the following table as a guide to working with the Attachments pane toolbar:
Item

Description
Click to display or hide the list of attached files.
This feature enables you to attach a file to the GPR line.
1 Click Attach File.
2 In the Attach File(s) dialog box, navigate to and select the file
you want to attach.
3 Click Open.
1 In the Attachments tab, select the item you want to delete.
2 Click Delete File.
3 In the message box, click Yes.
Note: Positioning files (GPS, Topography) cannot be deleted.
1 In the Attachments tab, select the item you want to open.
2 Click Open.
Note: if there is no application associated with the selected file
type, Windows will prompt you to select one from a list.
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Positioning Files

GPS and Topography files are special files called “Positioning Files”; they are always
listed first in the Attachments list. When attached, either automatically or manually, they
cannot be deleted, only replaced by another GPS or topography file.
If another GPS or topography file is attached, the user is prompted whether or not to
replace the current file. If they answer “Yes”, the new file is added to the list and the old
GPS or topography file is appended with the extension .BAK and kept as an attachment
for record-keeping but is not used for positioning.
GPS and topography files both contain elevation information but the topography file
takes precedence. Therefore, if both a GPS and topography file are attached, the
topography file elevations are used when plotting the data.
The GPS and topography file names must always match the name of the GPR line. If a
GPS or topography file with a different name is manually attached to a GPR line, the
name is changed to match the name of the GPR line. Further, these attached files will
be automatically renamed when the GPR line name is changed. Other attachments do
not follow this requirement.

3.7.2.2.1

GPS Files

Attaching a GPS file adds Latitude, Longitude, UTM coordinates, and GPS elevation to
every trace in the GPR line.
A GPS file is created by attaching a GPS system to the GPR system during data
collection. GPS files contain lines of standard GPS positional output text (called NMEA
strings) and the associated GPR trace number. When the GPS (or GP2) file is attached
to a GPR line, latitude, longitude, and GPS elevations for every GPR trace are
calculated and saved into the GPR line.
Some later GPR systems also save GP2 files, which contain GPS data in a different
format than the GPS file.
Note: EKKO_Project automatically creates a GP2 file if one doesn’t already exist.
GPS and GP2 files formats are defined in Appendix B – File Formats.
When GPS information is available, GPR lines plotted in LineView display the GPS
position of the current mouse cursor location on the status bar along the bottom of the
screen.

1

When a GPS file is created with the same name as a GPR line in the project folder, the
GPS file is automatically attached to the GPR line. GPS files, even those with different
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names, can also be attached manually. In this case the GPS file is copied, renamed to
the same name as the GPR line and attached.
A GPR line with integrated GPS is indicated by a small letter “g” beside the GPR line
name in Project Explorer.

3.7.2.2.2

GPS Elevations

GPS data contains an elevation value that is integrated with the GPR line. However, be
aware that if you are using a lower-end GPS system the elevation data may not be very
accurate; plotting the GPR line with an elevation axis in LineView usually provides poor
results with large vertical shifts in the data image. High-end GPS systems can provide
accurate elevation values that work well when the GPR line is plotted with an elevation
axis in LineView.

3.7.2.2.3

Topography Files

A topography file is a text file containing GPR line positions and the elevations at those
positions. When a topography file is attached to a GPR line, elevations for every GPR
trace are saved into the elevation field of the GPR trace header.
When elevation information is available, GPR lines can be plotted in LineView with an
elevation axis. This type of display can be invaluable for understanding the proper
spatial positioning of GPR reflections.


Each line of text must contain a pair of numbers representing position and elevation.

Topography file example:
0.0

935.8

10.1

933.9

22.7

930.3

30.5

932.7

34.6

936.5

The Topography file format is defined in Appendix B – File Formats.
Note: Topographic files (.top) are stored in the same units that the data was collected
in (meters or feet); however, the file could be viewed in a different unit. The units
used during collection are displayed in the Acquisition tab Positioning Pane.
When a topography (.top) file is available with the same name as a GPR line in the
folder, it is automatically attached to the GPR line. Topography files, even those with
different names, can also be attached manually. In this case the topography file is
copied, renamed to the same name as the GPR line and attached.
A GPR line with integrated topography is indicated by a small letter “t” beside the GPR
line name in Project Explorer.
If a topography file is attached after a GPS file is attached, the user is prompted to
confirm whether or not they would like to replace the GPS elevations with the elevations
from the topography file. If the answer is “Yes”, the topography file is attached. If the
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answer is “No”, the topography file is not attached. In other words, if a Topography file
has been attached, it is used for elevations.

3.7.3

Processing Tab

If GPR lines have been processed using the optional Processing module, the processing
details, including the name of the processes, the order the processes were applied, and
the details of the process parameters are listed in the Processes tab.
Only processed GPR lines are identified by a small letter “p” in the Project Explorer will
list processing information in the Processes tab. However, GPR Lines that have been
processed and then copied into a lineset will be listed but will not be identified by the
letter “p.” To learn more, see Processing Functions.

Note: Distance units (m/ft.) listed in the processes tab are always displayed in the
format the GPR line was collected in, even if the Units have been changed in
EKKO_Project.
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Toolbars

To manage how toolbars are displayed ion EKKO_Project, in the menu bar, click the
View Menu.

3.8.1

Standard Toolbar

The EKKO_Project Standard toolbar displays icons or text that represents features that
allow you to work with GPR data.

Use the following table as guide to working with the Standard Toolbar:
Field

Description

New
Click

to create a New project.

Open
Click

to Open an existing project.

Click

to Save the current project

Save
LineView
Select an item(s) in Project Explorer and then click
items in LineView.

to display the

SliceView
Select a grid in Project Explorer and then click
as depth slices in SliceView.

to display the grid

Metric
Click

to change units to Metric.

US Standard
GPR Summary
Report
Bridge Deck
Report

Click

to change units to US Standard (feet).

Click

to generate a GPR Summary Report.

Click

to generate a Bridge Deck Condition Report.

Pavement Report
Click

to generate a Pavement Structure Report.

Process
Click

to open the Processing dialog box

Undo Process
Click

to Undo Processing applied to checked GPR lines.
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Field

Description

Cut
Click
to Cut the selected or checked item(s) and place them on the
clipboard.
This enables you to remove a GPR line from a lineset and paste it into a
different lineset.
Note: a GPR line cannot be cut from a grid.
Copy
Click
to Copy the selected or checked GPR line(s), lineset, or grid,
and place them on the clipboard.
Paste
Click
to Paste the cut or copied GPR line(s), lineset, or grid from the
clipboard into the project.
Delete
Click
project.

to Delete the selected GPR line, lineset, or grid from the

Click

to display the this manual.

Help
Add or Remove
Buttons

Click the drop-down arrow beside the Help icon to add or remove buttons
from the Standard toolbar.
To learn more, see Add or Remove Buttons.

To display a brief description of the icon’s function, hold your mouse cursor over the icon
on the toolbar.
If a keyboard shortcut is associated with the toolbar item, it is displayed with the tool tip

A description also appears on the Status Bar at the bottom of the screen:

3.8.2

View Control Toolbar

The EKKO_Project View Control toolbar allows you to manage how to display images
in MapView and Line Preview.
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Use the following table as a guide to working with the View Control toolbar:
Field

Description

Scale Lines
Click

to show or hide Scale Lines in MapView.

Not available for Line Preview.
Zoom Out
Click

to display more of the MapView image.

For Line Preview, Zoom out shows more horizontal data in the window.
To learn more, see Zoom Out.
Zoom In
Click

to magnify the MapView image.

For Line Preview, Zoom in shows less horizontal data in the window.
To learn more, see Zoom In.
Zoom Window
Click
Preview.

to magnify a selected area within MapView or Line

To learn more, see Zoom Window.
Fit to Window
Click
to automatically zoom to fit all data in the MapView or Line
Preview windows.
To learn more, click Fit to Window.
Pan View
Click

to pan the Display area (drag and drop) in MapView.

Not available for Line Preview.
To learn more, see Pan View.
Measure
Click

to measure distance in the MapView window

Not available for Line Preview.
To learn more, click Measure.
Copy View
Click

to copy the active view to clipboard

To learn more, click Copy View.
Export View
Click
bmp, png etc.)

to export the active view as a graphics image file (jpg,

To learn more, see Export View to File.
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Field

Description

Save View
Click
to save the Active Window as an image file and attach it
to the project file. When the GPR Summary Report is selected, the user
can select from the images attached to project to appear in the report.
To learn more, see GPR Summary Report.
Add or Remove
Button

Click the drop-down arrow beside the Export View to File icon add or
remove buttons from the View Control toolbar.
To learn more, see Add or Remove Buttons.

3.8.2.1

Scale Lines

Scale lines are dashed lines that correspond to the X and Y axes label increment. They
can assist in determining an accurate XY position within the project data.

To display a axes scale lines in MapView, in the View Control toolbar, click

Scale lines
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Measure

To measure distance within the MapView, click
Click and drag the ruler icon (
want to measure.

.

) to span two points within the MapView that you

The measured distance is displayed in the status bar:
The first value indicates the straight line distance between the two points. The values
displayed in brackets represent the distance along the X-axis and Y-axis respectively.

3.8.2.3

Copy View

To copy the MapView image to the clipboard, click

.

This feature enables you to copy and paste the image to a document or image editor.

3.8.2.4

Export View to File

1. To export the MapView image to a file, click
.
2. In the Save As dialog box, navigate to, and select the folder you want to save this
image in.
3. Use the Save as Type dropdown to select the file format (jpg, bmp, gif, png or tiff)
4. Click Save.

3.8.2.5

Save View

To save the active window (Line Preview or SliceView window) as an image file and
attach it to the project file, click

.

The Save View button opens a dialog for naming the image. The default name is based
on what window is being saved (Line Preview, MapView, LineView or SliceView).
For MapView images, the default image name will include:


the depth of the slice being shown, if Slices are turned on.



PCD, if PCD is turned on.

When the GPR Summary Report is selected, the user can select from the images
attached to project to appear in the report.
To see a list of the images currently saved and available for the GPR Summary Report,
select the project item in Project Explorer and then open the Attachments Tab.
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Menu Bar

The EKKO_Project menu bar displays a number of options that allow you to create,
save, manipulate, and export GPR data.
Use the following table as a guide to working with the EKKO_Project menu bar:
Field
File

Description
Create a New project, or Open, Close, Save, Report, Export, or Exit
existing projects.
To learn more, see the File menu.

Edit

Update your project - add lines, linesets, or grids, rename files, or attach
files.
To learn more, see the Edit menu.

View

Display units in meters or feet, view data in Average Amplitude
Spectrum, Average Trace Amplitude, or Trace Plot graphs, or define
how the toolbars are displayed.
To learn more, see the View menu.

Tools

Access LineView, SliceView (optional), modify Project or Grid Position
Relationships, Processing (optional) and GPS routines.
To learn more, see the Tools menu.

Window

To open the Line Preview or MapView windows or tile the Line Preview and
MapView windows horizontally or vertically.
To learn more, see the Window menu.

Help

Display information about EKKO_Project, a PDF version of this manual, the
About dialog, and the EKKO_Project Registration. See Help.
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3.10 File Menu
Use the File menu to create a New project, Open, or Save files, create Reports, Export
lines, or Exit the EKKO_Project.
To open the file menu drop-down list, click File:

The following sections describe the File menu features:

3.10.1

New

1. To create a new project file, In the EKKO_Project menu bar, click File > New.
Alternatively, in the Standard Toolbar, click

.

2. In the Getting Started dialog box (Figure 1), in the Create a New Project pane
select one of the three data type options to add GPR data to a new project file:



Note: Project files can contain multiple grids and linesets.
To learn how to add more data to the current project file, see the Edit menu.

3.10.2

Open

1. To open an existing project (.gpz) file in EKKO_Project, click File > Open.
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Alternatively, in the Standard Toolbar, click

.

2. In the Open dialog (Figure 2), navigate to and then select the project you want to
open.
3. Click Open.

3.10.3

Close

1. To close the current project click File > Close
2. In the message box, to close the project and save your changes, click Yes.
To close the project without saving your changes, click No.

Figure 6: Save As dialog box

3. In the Save As dialog box, navigate to the folder you want to save the project to.
4. Click Save.

3.10.4

Save

1. To save the current project to a .gpz file, click File > Save.
Alternatively, in the Standard Toolbar, click

.

2. In the Save As dialog box, navigate to the folder you want to save the project to.
3. Click Save.
When a new project is saved, the .dt1, .hd, and all other ancillary files such as GPS
and topographic files are saved to a compressed .gpz project file.

3.10.5

Save As

1. To save the current project to a different folder and/or name, click File > Save As.
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2. In the Save As dialog box, navigate to the folder you want to the project to.
To save the project with a different file name, in the File name field enter the new
project name.
3. Click Save.

3.10.6

Import GPZ

1. To merge the data from an existing project (GPZ) file with the current project in
EKKO_Project (if a project file is already open), click File > Import GPZ.
2. In the Open dialog (Figure 2), navigate to and then select one or more projects (GPZ
files) you want to import and merge into the current project.
3. Click Open.
4. Data folders and grids in the imported project files are added to the current project
file.
5. Note that no interpretations are imported from the project file into the current
project. It is best to import and merge all the project files before adding
interpretations or processing data.

3.10.7

Export

Select Export to extract data files from a project and save them as GPR Line(s), Slices,
Average Trace Amplitude (ATA) plots, or Average Frequency Spectrum (AFS) plots.
1. To export data files, click Export.

2. In the drop-down list, click the format you want to save the file as.
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3.10.7.1 Lines
Select Line(s) to extract data from a project file and save them to a separate folder as
Line Data, CSV, or Text.
1. Click the Line(s) drop-down list to select the format you want to export line data to:

2. In the drop-down list, click the format you want to save the file in:






Line Data
SEG-Y
CSV
Text
Trace Headers

3.10.7.1.1 Line Data
Select Line Data to export selected GPR lines (.dt1 or .hd) and any files attached to that
data (such as GPS, topography, photos, etc.).
1. To export GPR lines from the project (.gpz) file to a different folder location click File
> Export > Line(s) >Line Data.

2. In the Select folder to export to dialog box, navigate to and then select the folder
you want to export the files to.
3. Click Select Folder.
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A dialog box opens displaying the exported lines.

\
Note: Interpretations are not saved when GPR lines are exported.

3.10.7.1.2 SEG-Y
Select SEG-Y to export GPR lines to a SEG-Y, a format commonly used for seismic
data. Selected GPR lines are converted to a file with the same name as the original
file(s) appended with a .sgy extension,
1. Click File > Export > Line(s) > SEG-Y.
2. In the Select folder to export to dialog box, navigate to and select the folder you
want to export the file to.
3. Click Select Folder.
A dialog box opens to display the folder that the .sgy lines were saved to.
The SEG-Y format is defined in Appendix B – File Formats.

3.10.7.1.3 CSV
Select CSV to export GPR lines to a comma separated value (CSV) file. This feature
converts selected GPR lines to a single file with the same name as the original file(s)
appended with a .csv extension,
4. Click File > Export > Line(s) > CSV.
5. In the Select folder to export to dialog box, navigate to and select the folder you
want to export the file to.
6. Click Select Folder.
A dialog box opens to display the folder that the .csv lines were saved to.
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7. To open a .csv file, navigate to the folder you saved the lines in and then click the
.csv file.
The CSV files can be read by spreadsheet software such as Microsoft Excel and GIS
packages.
The new file lists the data in a table that displays point amplitudes from each trace in
separate columns with trace numbers and position values at the top of each column
and point numbers and time values at the beginning of each row.

Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and
can be converted to millivolts by multiplying by 50/32767 = 0.0015259.
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3.10.7.1.4 Text
Select Text to export GPR lines to a text file. This feature converts GPR lines to a single
text file with the same name as the original file(s) appended with a .txt extension.
1. Click File > Export > Line(s) > Text
2. In the Select folder to export to dialog box, navigate to and select the folder you
want to export the file to.
3. Click Select Folder.
A dialog box opens to display the folder that the .txt lines were saved to.

4. To open a .txt file, navigate to the folder you saved the lines in and then click the .txt
file.
This format can be read by spreadsheet software, Microsoft Notepad, and WordPad.
The text file lists data in a table that displays point amplitudes from each trace in
separate columns with position values at the top of each column and time values at
the beginning of each row.
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The first value in this file is a placeholder and is always set to -999.
Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and
can be converted to millivolts by multiplying by 50/32767 = 0.0015259.

3.10.7.1.5 Trace Headers
Every time a GPR data trace is collected, as well as saving the trace amplitude
information, other parameters associated with that trace are saved to the “trace header”
in the data file.
The trace header consists of 25 floating point numbers. Parameters such as the trace
number, trace position, elevation data, Transmitter X, Y and Z positions, Receiver X, Y
and Z positions, GPS X, Y and Z positions and the time of day in seconds past midnight
when the trace data were collected, are saved to the trace header.
Exporting the trace headers allows the user to see the values of these parameters from
every trace header in the GPR line.
Select Trace Headers to export the GPR tracer header information to a CSV. The
selected GPR lines are converted to a file with the same name as the original file(s)
appended with a .csv extension,
1. Click File > Export > Line(s) > Trace Headers.
2. In the Select folder to export to dialog box, navigate to and select the folder you
want to export the file to.
3. Click Select Folder.
A dialog box opens to display the folder that the .csv lines were saved to. The CSV file
format allows the trace header information to be exported to programs like Microsoft
Excel.
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3.10.7.2 Slices
Use the Slices feature to export Average Trace Amplitudes for one or more intervals
from all the traces in the selected lines to a comma separated (.csv) file. Slices are
compatible with 2D plotting software applications such as Golden Software’s Surfer.
1. To export depth slice information from the project (gpz) file, click File > Export >
Slice.

The Slice Processing dialog box is automatically populated with default data.
2. Use the following table as a guide to working with the Slice Processing dialog box:
Field

Description

Units

Select an option to generate slices based on time (ns) or depth (m
or ft.).

Thickness

Enter the thickness for each slice, in terms of time (ns) or depth (m
or ft.).

Overlap

Enter the overlap percentage between slices.
Overlap represents the amount that each slice overlaps the
previous slice as a percentage of the slice thickness.

Depth Limit
Max/User
Number of Slices

The maximum depth (or time) that slices will be generated:



Select Max to generate slices up to the maximum line depth
Select User to generate slices up to the user defined depth

The number of slices in the slice export dialog is an estimate.
For large antenna separations and low signal velocities the number
of slices exported in depth mode may be fewer since the slicer
uses individual depth for each line as shown in LineView depth axis
at the selected velocity.
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Field
Velocity

Description
Enter the signal velocity for generating depth slices.
Click

to learn more about signal velocity

3. Click OK.
4. In the Select folder to export to dialog box, navigate to and then select the folder
you want to save the slices to.
5. Click Select Folder.
Windows Explorer opens to display where you saved the slices.
6. Double-click a .csv file to display the results:
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3.10.7.3 Average Trace Amplitude
Select Average Trace Amplitude (ATA) plot to display the average rectified signal
amplitudes (in microvolts) for one or more GPR lines. To learn more, see Average Trace
Amplitude Plot.
Use ATA to display how rapidly the signal amplitude decays into the background, giving
you an idea of the maximum penetration of the GPR system.
The following procedure describes how to export the average rectified trace amplitudes
for all the traces in the selected GPR line(s) to comma separated value (.csv) files:
1. Click File > Export > Average Trace Amplitude (ATA).
2. In the Select target folder for the ATA report dialog box, navigate to and then
select a target folder.
3. Click Select Folder
A dialog box opens to display the folder containing the reports in Windows Explorer.
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3.10.7.4 Average Frequency Spectrum
Select Average Frequency Spectrum (AFS) to display the average frequency
spectrum of the selected GPR line(s). To learn more, see Average Frequency Spectrum.
Use AFS to determine the frequency content of a GPR line in order to decide if filtering is
required to remove unwanted frequencies such as high frequency noise. If required,
lowpass, highpass or bandpass filtering can be applied (to learn more, see Filtering.
The following procedure describes how to export the average frequency spectrum for all
the traces in the selected GPR line(s) to comma separated (.csv) files:
1. Click File > Export > Average Frequency Spectrum (AFS).
2. In the Select target folder for the AFS report dialog box, navigate to and then
select a target folder.
3. Click Select Folder
A dialog box opens to display the folder containing the reports in Windows Explorer.
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Recent Files

1. To re-open a project (.gpz) file that you recently worked with, click File.

2. In the drop-down list, click one of the projects listed in the recent files area.

3.10.9

Exit

1. Click File > Exit to close all windows that are open as part of the current
EKKO_Project session and exit the application.
2. In the message box, click Yes to save the project file.
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3.11 Edit Menu
The EKKO_Project menu bar Edit menu contains many features that allow you to add
and update GPR project files.
To open the edit menu drop-down list, click Edit:

The following sections describe the Edit menu features:

3.11.1

Add Grid

1. To add a grid to the current project file, click Edit > Add Grid.
2. In the Open dialog box, navigate to and then click the grid file you want to add.
3. Click Open.
The project file grid name defaults to the same name as the .gfp file.

3.11.2

Add Lineset

A Lineset represents a number of GPR lines grouped into a single folder. Select Add
Lineset to create and then populate a lineset folder.
1. Click Edit > Add Lineset.
1. In the Select folder to import Lines From dialog box, navigate to and then select
the folder you want to add.
2. Click Select Folder.
The lineset and lines are displayed in Project Explorer.

3.11.3

New Lineset

Select New Lineset to create a New Lineset folder in the current project file.
1. Click Edit > New Lineset.
The lineset name appears in the Project Explorer window.
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Add Line(s) to Lineset

Select Add Line(s) to Lineset to add lines to a Lineset in a project.
1. Click Edit > Add Lines to Lineset.
2. In the Open dialog, navigate to and then select one or more GPR (.hd) lines.
3. Click Open.
The data files are added to the Lineset and are displayed in the Project Explorer.

3.11.5

Rename

Select Rename to change the name of the project, grid, lineset, or GPR line in a lineset.
Note: A GPR line name in a grid cannot be renamed.
1. To rename an item, in Project Explorer, select the item you want to rename.

2. In the menu bar, click Edit > Rename.
A box appears around the item name signifying that the name is now editable.
3. Type the new item name and then press Enter.
Note: Certain characters, such as periods and slashes are not valid in names. If you
enter one of these characters it will be automatically replaced with an underscore.

3.11.6

Attach File

Select Attach File to attach GPS files, topography files, photos of the line location,
videos of the area, or voice recordings of information relevant to the GPR project, grid,
lineset, or line.
1. To attach a file to the selected GPR data line, lineset, grid, or project, click Edit >
Attach File.
2. In the Attach Files dialog box, to navigate to and then select the file you want to
attach.
The file is listed in the Attachments tab. To learn more, see Attachments Tab.

3.11.7

Remove

Use Remove > Interpretation Observations to remove interpretations from MapView.
For example, since interpretations are included when a GPR line is copied, you may
want to remove interpretations from the copied line.
1. To remove interpretations from GPR line, lineset, or grid, click Edit > Remove >
interpretation Observations.
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2. To remove the observation, in the message box, click Yes.

3.11.8

Cut

To remove the selected GPR line, lineset or grid from the project, click Edit > Cut.
This enables you to remove a GPR line from a lineset and paste it into a different lineset.
Note: a GPR line cannot be cut from a grid.

3.11.9

Copy

To copy an item, click Edit > Copy.
Use the Copy feature to:



Copy a GPR line, lineset, or grid and display it in LineView or Process the item
differently than the original.
Copy and then paste the selected lineset or grid back into the project.
Note: GPR lines in a grid can be copied, but they must be pasted into a lineset; they
cannot be pasted into a grid.

3.11.10 Paste
Select Paste to add a GPR line from one lineset to a different lineset.
To paste an item, click Edit > Paste
Use the Paste feature to:



Paste a copy of a GPR line, lineset, or grid into LineView, or Process the item
differently than the original.
Paste a copied or cut lineset or grid back into the project.
Note: copied GPR lines must be pasted into a lineset; they cannot be pasted into a
grid.
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3.11.11 Delete
To remove a grid or lineset from a project, or delete a GPR line from the lineset in the
project, click Edit > Delete.
Note: GPR lines cannot be deleted from a grid.
To delete a line or lines from a grid, use the GFP_Edit utility program that accompanies
SliceView.
Caution: Removing a GPR line from the project file may result in the total loss of the
GPR data line, interpretations, and associated files (.gps, .top, and .ini) unless a
separate copy of the original data files exists.
The original data files may exist if the GPR lines were added to the project file rather
than being embedded in the project (.gpz) file.
If the project (.gpz) file was generated by the Sensors & Software GPR system, a copy
of the GPR line(s) can be made clicking File > Export > Lines; this saves the original
.dt1 and .hd files, and not the interpretations.
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3.12 View Menu
The EKKO_Project View menu contains many features that allow you to change the way
information is displayed in EKKO_Project.
To open the view menu, click View:

The following sections describe how to work with the View menu features:

3.12.1

Units

1. To display units of measurement in EKKO_Project in meters or feet, click Units.
2. In the drop-down list, click m (metric) or ft. (US standard).

Changes in units of measurement affects the following EKKO_Project features:






Line Preview
MapView
LineView
Reports (including Bridge Deck Condition and Pavement Structure Reports)
Processing
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Average Trace Amplitude

Average Trace Amplitude (ATA) plots display the average signal amplitudes (in
microvolts) for one or more selected GPR lines. Data is Dewowed before being
displayed (to learn more, see Dewow).
ATA plots enable you to display how quickly signal amplitude decays to the background
noise level, providing an indication of the maximum penetration in the survey area.
1. To display all the currently checked GPR lines in an Average Trace Amplitude (ATA)
plot, click View > Average Trace Amplitude Plot (ATA).
The ATA plot is greyed out if no lines are selected.

Figure 7: Average Trace Amplitude Plot

2. Use the following table as a guide to working with the Average Trace Amplitude Plot:
Item

Description

Resize Window

Drag and drop a corner or edge of the window to resize it. The
Window can also be maximized using the Maximize button in the top
right.

Pan View

Hold the right-click button and drag the mouse in the direction you
want to move the image.

Default View Limits

Click Default View Limits to return to the original plot display.

Zoom

1 Left-click the image to define the top left corner of the zoom box
2 Hold the left-click button and drag the mouse to the bottom right
corner of the zoom box.
3 Release the mouse button and the image zooms to the box
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Item
Amplitude (mV)

Description
The GPR signal amplitude in millivolts (mV).
Move the cursor along the time axis to display the time and GPR
signal amplitude.
The signal amplitude typically starts at the background noise level on
the left. At zero time, a strong amplitude signal occurs when the
GPR system fires its transmitter. At later times, the GPR signal
slowly decays back to the background noise level (providing the
recording time window is long enough). The slope the signal level
drops depends on the material being surveyed.

Time (ns)

The time in nanoseconds from the start of the recording window.
Time before zero time is displayed as a negative value.
The time at which the signal level drops back to the background
noise level is the maximum penetration time. This can be converted
to the average maximum depth of penetration if a radar velocity for
the material is known.

3.12.2.1 Plot
1. Click Plot to display the ATA plot options drop-down list.

2. Use the following table as a guide to working with the Plot drop-down features:
Item
Print
Export Image

Description
To print the ATA plot, click Print.
1 To send the ATA plot as an image, click Export Image.
2 In the Save As dialog box, navigate to the folder you want to
send this image to.
3 Click Save.

Copy Image to
Clipboard
Legend
Close

To copy an ATA plot image to paste to a document, click Copy
Image to Clipboard.
1 To define where on the ATA plot the legend is click Legend.
2 In the drop-down list click Top, Bottom, Left, Right, or Hide.
To close the ATA plot, click Close.

3. To export the data used to create the plot, click File > Export. > Average Trace
Amplitude.
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Average Frequency Spectrum

Average Frequency Spectrum (AFS) plots display the average frequency spectrum of
the selected GPR line(s). Data is dewowed before being displayed (to learn more, see
Dewow).
Select AFS to determine the frequency content of a GPR line to decide if filtering is
required to remove unwanted frequencies like high frequency noise. If so, lowpass,
highpass, or bandpass filtering can be applied (to learn more, see Filtering).
1. To display all the currently checked GPR lines in an Average Amplitude Spectrum
(AFS) plot, click View > Average Frequency Spectrum Plot (AFS).
The AFS plot is greyed out if no lines are selected.

Figure 8: Average Frequency Spectrum Plot

2. Use the following table as a guide to working with the Average Frequency Spectrum
Plot:
Item

Description

Resize Window

Drag and drop a corner or edge of the window to resize it. The
Window can also be maximized using the Maximize button in the top
right.

Default View Limits

Click Default View Limits to return to the original plot display.

Zoom

1 Left-click the image to define the top left corner of the zoom box
2 Hold the left-click button and drag the mouse to the bottom right
corner of the zoom box.
3 Release the mouse button and the image zooms to the box
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Item
Amplitude (mV)

Description
The GPR signal amplitude in millivolts (mV).
Move the mouse cursor along the frequency axis to display the
frequency and amplitude.
The signal amplitude typically starts at the background noise level on
the left.

Frequency (MHz)

The Frequency in MHz.
The displayed frequency range defaults to zero to the Nyquist
frequency (calculated from the temporal sampling interval for the GPR
line).

Note: Sensors & Software antennas center frequency is measured in air. For
example, 100 MHz antennas produce a center frequency of about 100 MHz when
data is collected in air. The center frequency of data from antennas placed on the
ground will be lower in frequency than the stated frequency of the antenna. For
example, the center frequency of data collected with 100 MHz antennas is often 60 to
70 MHz.
3. To export the data used to create the plot, click File > Export. > Average
Frequency Spectrunm.

3.12.3.1 Plot
Click Plot to display the AFS plot options drop-down list.
To learn about the Average Frequency Spectrum Plot feature, click Plot.
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Trace Plot

View Traces to display subtle features in the data file, or view the effect of different
editing and processing types on individual traces. Only a single line can be loaded into
the trace plot at a time. Data is dewowed before being displayed (to learn more, see
Dewow).
Viewing traces can also help you determine if the first break offset needs to be edited.
Normally the first break should occur at the first large deflection in the signal. If not, time
scales and depth scales on section plots will be inaccurate. .
1. To display all the currently checked GPR lines in a Trace plot, click View > Trace
Plot.
The Trace plot is greyed out if no GPR lines are selected.

Figure 9: View Traces Plot

2. Use the following table as a guide to working with the Trace Plot:
Item

Description

Resize Window

Drag and drop a corner or edge of the window to resize it. The
Window can also be maximized using the Maximize button in the top
right.

Default View
Limits

Click Default View Limits to return to the original plot display.
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Item
Zoom

Description
1 Left-click the image to define the top left corner of the zoom box
2 Hold the left-click button and drag the mouse to the bottom right
corner of the zoom box.
3 Release the mouse and the mage zooms to the box

Amplitude (mV)

The GPR signal amplitude in millivolts (mV)
Move the cursor along the time axis to display the time and GPR
signal amplitude.
The signal amplitude typically starts at the background noise level
on the left. At zero time, a strong amplitude signal occurs when the
GPR system fires its transmitter. The GPR signal slowly decays
back to the background noise level, providing the recording time
window is long enough.

Time (ns)

The time in nanoseconds from the start of the recording window.
Time before zero time is displayed as a negative value.

Trace

The displayed trace.
Click the up and down arrows to display other traces.

Position

The position of the displayed trace on the GPR line. The position is
based on the trace number and the step size

3.12.4.1 Plot
Click Plot to display the View Traces plot options drop-down list.
To learn about the View Traces Plot feature, click Plot.

3.12.5

Zoom

3.12.5.1 Zoom Out
To decrease the magnification of the MapView image, click View > Zoom > Out.

3.12.5.2 Zoom In
To increase the magnification of the MapView image, click View > Zoom > In.
When you zoom in to display a portion of the project data, an icon appears in the lower
left corner of MapView to indicate that data exists outside the current view (see Pan).

3.12.5.3 Zoom Window
To magnify a selected area of MapView, click View > Zoom > Zoom Window and then
click and drag a rectangle in the area of interest.

3.12.5.4 Fit to Window
To adjust the zoom to fit all the data in the MapView click View > Zoom > Fit to
Window.
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Pan

To reposition the MapView, click View > Pan.
Click and drag the cursor (
) to move the MapView within the Display pane. Panning
does not change the location or magnification of objects on your drawing; it changes
only the view.

Panning or zooming images within MapView prompts the following icons to be displayed:
Indicates that some of the data is outside the current window.
Indicates that all of the data is outside the current window. Click View > Zoom >
Fit to Window to see all the data in the project in the MapView window.

3.12.7

Use Getting Started dialog

When a new project is created, the Getting Started dialog (Figure 1) automatically opens
to guide you through creating a project file.
To disable this feature, click View and then uncheck Use Getting Started dialog.
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Toolbar Text

EKKO_Project enables you to display/hide the text that appears below each toolbar icon.
Select View > Toolbar Text to display text below each icon:

To display the toolbar icons without text, reducing the size of the toolbar, select View
and then uncheck Toolbar Text.

3.12.9

Toolbars and Docking Windows

Select View > Toolbars and Docking Windows to view or hide the following features:







Standard Toolbar
Project Explorer
Acquisition Tab
Attachments Tab
Processing Tab

3.12.9.1 Customize
Customize is standard Microsoft functionality; for more details see Microsoft
documentation.
To modify the Commands, Toolbars, Keyboard, Menus, and other Options in
EKKO_Project, click View > Toolbars and Docking Windows > Customize.

3.12.9.1.1 The Commands Tab
Use the Commands tab to display all commands available to add to a toolbar.
1. The Commands tab lets you see all the commands available to add to a custom or
existing toolbar. To determine which commands will be displayed in the menu bar,
click the item in the Categories pane.
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2. To display a description of the command, click a menu item in the Commands pane.

3. To exit the Customize window, click Close or click another tab to view more
information.
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3.12.9.1.2 Toolbars Tab
1. To display the available Toolbar options, click the Toolbars tab.

2. Use the following table as a guide to working in the Toolbars tab:
Field
Toolbars

Description
The Toolbars field displays the available menu bars.
To display or hide a toolbar in EKKO_Project, select/deselect the checkbox
next to the toolbar name.

Reset

In the Toolbars field, select the menu bar(s) that you want to return to the
default setting and then click Reset.

Reset All

To return all toolbars to their default view, click Reset All.

New

1

To add a new toolbar to EKKO_Project, click New.

2 In the Toolbar Name field, type the name of the new toolbar.
The new toolbar is displayed in the Toolbars field.
Rename

To Rename a toolbar that you have added to EKKO_Project:
1 In the Toolbars pane, select the toolbar you want to rename.
2 Click Rename.
3 In the Toolbar Name dialog box, type the new toolbar name.
4 Click OK.

Delete

To Delete a toolbar that you have added to EKKO_Project:
1 In the Toolbars pane, select the toolbar you want to rename.
2 Click Delete.
3 In the confirmation dialog box, click Yes.

Show text
labels

To display text descriptions with the toolbar icons, click the Show text
labels checkbox
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3.12.9.1.3 Keyboard
To manage how your keyboard interacts with EKKO_Project, click the Keyboard tab.
Use the Keyboard tab to assign keyboard shortcuts to any feature in the File, Edit,
View, Tools, Help, or All Commands.

1. To create a new keyboard shortcut, in the Category drop-down list, click one of the
following options:

Note: Each Category displays a different list of commands.
2. In the Commands pane, click the command that you want to apply a hotkey shortcut
to.
A brief description of the command is displayed in the Description area.
Any existing shortcuts associated with the selected command are displayed in the
Current Keys pane.

3. In the Set Accelerator for drop-down list, click an option.
4. To create a new hotkey shortcut, select the Press New Shortcut Key field and then
press a shortcut combination on your keyboard.
The shortcut is displayed in the Press New Shortcut Key field.
67

EKKO_Project User’s Guide

EKKO_Project Interface

5. Click Assign to assign the shortcut to the selected command.
Press Remove to remove a shortcut from a command.
Press Reset All to remove all shortcuts.

3.12.9.1.4 Menu
1. To change the items displayed in the menu bar, click the Menu tab.

2. In the Application Frame Menus pane, click the Show Menus for drop-down list.
3. Click one of the following options:

Click Reset to abandon your changes.
4. To apply animations to the menu, click the Menu animations drop-down list and
select one of the following options:

5. To apply shadows to the menu items, select the Menu shadows option.
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6. To allow context menus to be displayed, in the Context Menus pane, click the Select
context menu drop-down list to select one of the following:

Click Reset to abandon all your changes.
7. Click Close to close the window.

3.12.9.1.5 Options
1. To define your toolbar and menu options, click the Options tab.

2. Use the following table as a guide to working with the Options tab:
Field

Description
Toolbar

Show Screen Tips on
toolbars

Select this option to display text screen tips when you hold your
mouse over the toolbar icon.

Show shortcut keys
in Screen Tips

Select this option to display text keyboard shortcuts when you hold
your mouse over the toolbar icon.

Large Icons

Select this option to display the large toolbar icons.
Personalized Menus and Toolbars

Menus show recently
used commands first

Select this option to place the commands you most recently used
at the top of the drop-down list.
Click the arrow (>) to display other menu options,
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Field

Description

Show full menus
after a short delay

Select this option to first display only the most recent commands
and then display the full menu after a few seconds.

Reset my usage data

Select this option to reset the recently used order.

3. Click Close to close the window.

3.12.10 Status Bar
To display information in the Status Bar at the bottom of the EKKO_Project window, in
the menu bar, click View > Status Bar.

To not display information in the status bar, de-select the Status Bar option.

3.12.11 GPS Format
To modify the format of the GPS information in the Status Bar at the bottom of the
EKKO_Project window, in the menu bar click View > GPS Format.

3.12.11.1

Latitude/Longitude

If Latitude/Longitude is selected with the checkbox, the display options are:
1) Degrees Minutes Seconds
2) Decimal Degrees
The options for the Hemisphere are:
1) Do not show
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2) Show as a Positive (+) or Negative (-) sign. A plus (+) sign if Latitude is in the
Northern hemisphere or Longitude is in the Eastern Hemisphere and a minus (-)
sign if Latitude is in the Southern hemisphere or Longitude is in the Western
Hemisphere.
3) Letter: For latitude, “N” for North or “S” for South. For Longitude, “E” for East or
“W” for West.
4) Word: For latitude, “North” or “South”. For Longitude, “East” or “West”.
A sample of the current GPS output is shown at the bottom of the dialog box.

3.12.11.2

UTM

If UTM is selected with the checkbox, the Reference Ellipsoid can be selected from the
drop-down list. The default is WGS-84.
To display the UTM Zone Number and/or the UTM Letter Designator, select those
options.
A sample of the current GPS output is shown at the bottom of the dialog box.
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3.13 Tools Menu
The EKKO_Project Tools menu contains many features that allow you work in LineView,
and the optional SliceView and Process views within EKKO_Project. The Tools menu is
also used to produce various reports using the GPR data and images in the project.
To open the tools menu drop-down list, click Tools:

The following sections describe how to work with the Tool menu features:
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LineView

LineView displays cross-sectional views of GPR lines; you can change the display
settings such as color table, gain, and axes.
1. To display a GPR Line name in the LineView module, in Project Explorer, select a
line.
2. Click Tools > LineView.

If the optional Interpretation module is enabled, use LineView to add interpretations such
as, Points, Polylines, Boxes, and Annotations to the GPR Line which can be listed in the
Project Report (CSV).
Only the selected GPR Line or those checked in to Project Explorer are displayed in
LineView, however all GPR Lines in the project can be displayed using the LineView
toolbar Project List drop-down.
To learn more about using LineView to display GPR lines and add Interpretations, see
the LineView User’s Guide.
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SliceView

Use the optional SliceView module to generate depth slices with highly detailed
subsurface information for GPR data collected in a grid. Viewing data as a series of
depth slices enhances GPR data interpretation.
1. To display a grid in SliceView, in Project Explorer, select a grid.
2. Click Tools > SliceView.
The following grid image displays the relationship between depth slice images and X
and Y GPR line images.

When GPR responses are displayed as depth slices, you can see the spatial correlation
of targets, making interpretation easier as you can differentiate real targets from targets
of no interest. For example, responses from utilities tend to produce linear targets while
local targets, such as rocks, appear as point targets. This type of display can greatly
enhance the interpretation of large data volumes.
SliceView is designed to process GPR grid data to enhance targets and create depth
slices.
Use SliceView to:





Analyze grid data by viewing depth slices at increasing depths
Reprocess grid data using different velocities
Save depth slices as images
Display depth slices generated from grid data collected with a GPS on Google Earth.
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Export grid data to 3D data files and 3D visualization software (available from
Sensors & Software)

To learn more about using SliceView to display depth slices, see the SliceView User’s
Guide.

3.13.3

Report

EKKO_Project can generate several reports from data at fiducial markers and
interpretations added to the project data. Reports are output in several formats including
Adobe Acrobat (.pdf), Google Earth (.kmz), Comma Separated Values (.csv), and
AutoCAD (.dxf) files.
1. Click Tools > Report.

2. In the drop-down list, select a report format:







GPR Summary Report (PDF)
Google Earth (KMZ)
Project Report (CSV)
CAD (DXF)
Bridge Deck Condition Report (PDF)
Pavement Structure Report (PDF)

3.13.3.1 GPR Summary Report (PDF)
The GPR Summary Report allows users to take data images saved of EKKO_Project
windows and their own photographs and images attached to the project, add text and
include them in a PDF report.
Images saved from EKKO_Project windows include the Line Preview and MapView
windows (see Save View) as well as images of windows from the optional LineView and
SliceView modules.
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As well, for some newer GPR systems, such as the LMX200 Enhanced, screen captures
saved in the field (by pressing the camera button) are also saved in the project file and
are available for inclusion in the GPR Summary Report.
To see a list of window images currently saved and available for the GPR Summary
Report, select the project item in Project Explorer and then open the Attachments Tab.
Photographs and other images attached to the project file, grid folder, lineset folder or
individual GPR line in the project are available to include in the report. For details on
attaching a file, see Attachments Tab.
1. To generate a GPR Summary Report (pdf) click Tools > Report > GPR Summary
Report.
2. A dialog opens, displaying all the data images available to include in the report.
Click on the images to include or click on the Select All checkbox in the bottom left
corner to quickly include all the images.

3. Once the desired images are selected, they appear in the bottom of the dialog.
Change the order of the images by dragging and dropping them in the desired order
for the report.
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4. Select Generate Report button. A preview of the report appears.
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5. The Report preview is editable, with many of the fields filled in automatically. Users
can modify titles and comments for each image. Note that all text entered into the
text boxes here is lost when you leave this dialog by pressing Save or Exit.
6. If you want to make changes to the images in the report, select the Back button to
move back to the previous screen. Text entered into text boxes before pressing
Back is saved.
7. The user can add their own logo to the top left-hand corner of the report by clicking
on the “click here to add logo” link, and selecting an image file.

The logo image is automatically remembered for that installation of EKKO_Project,
so the logo file only has to be selected once.
To clear the current logo image, select the Clear Logo button.
8. When the editing of the report is complete, save the report as a PDF document by
clicking the Save button. Providing the computer has PDF reader software installed
(it may be necessary to install Adobe Acrobat Reader from www.adobe.com), the
PDF file opens.
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3.13.3.2 Google Earth (KMZ)
Projects containing GPR lines and grids collected using GPS can be written to a Google
Earth (.kmz) report file and displayed in Google Earth. The path of the GPR lines, any
fiducial markers added during data collection, and post-processing interpretations (using
the Interpretations Module in LineView) are displayed on Google Earth. To enable or
disable these items, select the corresponding check-box in the Google Earth Places
window.
9. To generate a Google Earth (.kmz) report file for GPR lines in the project (.gpz) file
with GPS, click Tools > Report > Google Earth.
10. A dialog opens to define the color and thickness of the GPS path when plotted on
Google Earth:

Use the dropdowns to select a new color or width.
11. In the Save As folder, navigate to the folder you want to save the file to.
12. Click Save.
Google Earth opens to display a satellite image of the data collection site.

Figure 10: Google Earth image of the data collection site with the GPR line survey path in red and utility
point interpretations as pink and light blue dots.
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3.13.3.3 Project Report (CSV)
Fiducial markers are added to the data during data collection and Interpretations are
added during post-processing using the optional Interpretation module in LineView.
Exporting the fiducial markers and interpretations to spreadsheet-type files (.csv) allows
you to transfer the information to third-party software applications such as Excel and
Geographical Information Systems (GIS).
Before adding interpretations, decide whether to plot data with a depth axis or an
elevation axis.
To include observation values in the report by elevation rather than depth, add the
Interpretations after one of the following:



the GPR line has topographic data added that will not be changed
the GPR line is plotted with an elevation axis using a velocity value that will not be
changed
Note: Changing either of these conditions after adding interpretations shifts the
vertical positions of the interpretations and is not recommended.

Changing the depth or elevation axis velocity in LineView changes the depth and
elevation values.
1. To generate a Project Report, click Tools > Report > Project Report.

Alternatively, from the Standard Toolbar, click

.

Figure 11: Select target folder for export

2. In the Select target folder for the report dialog box, navigate to and then click the
folder to save the report files to
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3. Click Select Folder.
4. In the Report dialog box, enter the Polyline Output Interval (the horizontal distance
between points on any polylines in the project).

The Project Report Options dialog box opens whether polyline interpretations were
added or not, if you do not have any polyline interpretations click OK to ignore the
dialog.
5. Click OK.
A dialog box opens to display the folder that the .csv lines were saved to.

The types of .csv files generated are:






.csv files for each interpretation
.csv files for each GPR line
A .csv file containing all interpretations sorted by interpretations
A .csv file containing all interpretations sorted by GPR line
A .csv file for all fiducial markers
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Figure 12: Example of Project Report

3.13.3.4 CAD (DXF)
Projects can be written to a CAD report (dxf) file. The path of the GPR grid lines, the
GPS path for GPR lines collected with GPS, fiducial markers added during data
collection, and post-processing point interpretations (using the Interpretation Module) are
saved as layers in the DXF file.
Exporting this information to a .dxf file allows you to transfer the information to third-party
CAD programs. The Voxler software, if available, reads .dxf files. If necessary, free
CAD (.dxf) file viewers can be found on-line.
1. To generate a CAD (dxf) report file, click Tools > Report > CAD (DXF).
2. Use the dropdown box in the dialog box to select the coordinate system to save with
the DXF file:

The options are Project (Local X, Y), or, if a local-global coordinate relationship has
been established (usually by GPS data), UTM and Latitude-Longitude options are
also available.
UTM is usually selected to open the GPR report in AutoCAD programs while
Latitude-Longitude is the choice for GIS programs. When UTM or LatitudeLongitude is selected, a projection file (.prj) is generated that lists the projection
details. It is important to keep this file with the .dxf file when importing the data into
third-party programs such as ArcGIS.
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The projection file always uses the WGS84 reference ellipsoid for UTM and
latitude/longitude outputs.
3. In the Save As folder, navigate to the folder you want to save the file to.
4. Click Save.

3.13.3.5 Bridge Deck Condition Report (PDF)
If the optional Bridge Deck Condition Report module is enabled, projects containing GPR
lines collected using GPS or grids where point interpretations have been added to rebar
responses are processed to generate a Bridge Deck Condition Report.
The report requires positioning information so it will only run if the GPR lines were
collected in a grid or with GPS.
Select the GPR lines to include in the report in Project Explorer. If no GPR lines are
selected, all the lines in the project with point interpretations are included in the report.
Select Tools > Report > Bridge Deck Condition Report or select the Bridge Deck
Report button from the Toolbar:

The Bridge Deck Condition dialog opens:

An error message “There is insufficient data to generate the bridge deck condition
report” usually means that there are too few picked points in the data or they are too
widely scattered to generate an amplitude map image and good statistics.
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Field
Velocity

Description
Velocity used to migrate the rebar hyperbolas to point responses for amplitude
analysis. Also used to calculate rebar depths.
Local uses the GPR line velocities set in LineView (if not set in LineView, default
is 0.10 m/ns or 0.328 ft/ns).
Average uses the average velocity of all the GPR line velocities set in LineView.
Manual uses a velocity entered by the user for all GPR lines.

Interpolation
Limit

The Bridge Deck Condition Report generates an amplitude map image by
interpolating data into the gaps between GPR lines. As the GPR line separation
increases, interpolating data into the gap is less desirable as artifacts may be
created in the image.
If set to Auto, the value is calculated based on the average rebar spacing in the
data set to provide a “solid” map image with few or minimal gaps.
Manual uses an interpolation limit value input by the user.
The interpolated Limit calculated by Auto is listed in the report. The user can
regenerate the report using a Manual interpolation limit, if desired.

Interpretatio
n

Select the name of the Point Interpretation to process for the report. The
dropdown lists all the “Point” interpretation names added to GPR lines in the
project (or selected lines). Only one interpretation is used to generate the report.

Processing
Type

Absolute Amplitude produces a map image plotted in signal amplitude values
of millivolts (mV). Higher values indicate higher GPR signal amplitudes.
ASTM D6087-8 produces a map image plotted in signal amplitude values of
decibels (dB) based on the processing outlined in ASTM D6087-8 –“Standard
Test Method for Evaluating Asphalt-Covered Concrete Bridge Decks Using
Ground Penetrating Radar”. Higher values indicate higher GPR signal
attenuation. The reference amplitude is the median of the top 10% of the picked
rebar.

Generate
Report

Select to generate the Bridge Deck Condition Report.
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Field

Description

Export CSV

Export the calculated amplitude value (in mV or dB), Latitude-Longitude and
UTM coordinates for each picked rebar to a .csv file. This allows the user to
import the data into s third-party software for interpolation, image generation
and/or further analysis.

After generating a report, a preview is displayed. There are several fields in the report
that are auto-filled with known information or the user can add information. There are
also options to modify the amplitude image map. The Bridge Deck Analysis Report
includes:
1. Bridge deck name and description including:
a.
b.
c.
d.
e.
f.

number of lanes
surface material
surface condition
expansion joints
divided center median
additional information

2. Bridge deck location description (user input) and the GPS coordinates of the
center of the bridge deck
3. GPR survey details including:
a. type of GPS
b. GPR system
c. GPR system configuration
4. Processing Summary listing:
a.
b.
c.
d.

Processing Type (Absolute Amplitude or ASTM D6087-8)
GPR Velocity
Analysis Date
Total number of rebar responses picked and processed to generate the
amplitude image
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e. Interpolation Type (Auto or Manual with value listed)
5. Bridge deck rebar amplitude image:
a. With user-selectable Color Palette
b. Export to .png, .bmp or .jpg graphic file formats
c. Amplitude range plotted can be set to Automatic (full range) or Manual
(user sets the range)
6. Statistical summary of the rebar measurements including:
a. Minimum, maximum and average amplitude
b. Minimum, maximum and average rebar depth
c. Minimum, maximum and average rebar spacing
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Field

Description

Save

Save the current report to an Adobe Acrobat PDF file.

Export
Image

Export Response Amplitude map image to .png, .bmp or .jpg graphic file formats

Export to
Google
Earth

Export Response Amplitude map image to a .kmz file format so the image can be displayed
in Google Earth at the survey location. The image elements can be modified in Google
Earth using the checkboxes and other options under Places > temporary Places.

Color
Palette

Select a color map from the dropdown list to display the response amplitude image in
various colors.
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Field
Color
Palette
Range

Description
The range of amplitude values to display in the map image.
Automatic uses the full range of calculated of response amplitudes in the data set.
Manual uses the range set by the user. Changing the range is often used to emphasize
high or low amplitude areas of the map or if you want to compare maps from more than one
bridge deck using the same range.
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3.13.3.6 Pavement Structure Report (PDF)
If the optional Pavement Structure Report module is enabled, Projects containing GPR
lines where polyline interpretations have been added are processed to generate a
Pavement Structure Report.
The report requires:


The polylines placed in the GPR lines must not change order (shallow to deep)



The report will not plot the thickness of layers under areas where portions of the
shallower layers have not been picked

Select the GPR lines to include in the report in Project Explorer. If no GPR lines are
selected, all the lines in the project with polyline interpretations are included in the report.
Select Tools > Report > Pavement Structure Report or select the Pavement Structure
Report button from the Toolbar:

The Pavement Structure dialog opens:
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Field
Layers to
Report

Description
The dialog lists the names of all the polyline interpretations added to the GPR
line(s). The default is to include all layers in the report but the user can uncheck
any layers to ignore.
Each layer has a velocity value. This is the average velocity from the surface to
the bottom of the layer.
An error message is generated if a velocity is used that is impossible, that is, it
causes layers to switch the order they appear from shallow to deep.

Report
Step

The distance between reported depth measurements along the GPR line. The
smaller this value, the more detail there is in the charts in the report.

Chart
Depth

The total depth to plot in the chart.
Auto sets the maximum depth in the chart to the deepest point of the deepest
layer.
Manual allows the user to set the maximum value to plot. A manual value is often
used so all GPR line structure charts are plotted to the same depth for easier
comparison.

Chart
Width

The total horizontal distance depicted in each Pavement Structure chart. Setting
this distance allows all the data to be displayed on one chart or broken up into
several charts with the specified width.
Defaults to 500 meters or 1000 feet.

Generate
Report

Select to generate the Pavement Structure Report.

Export CSV

Export the pavement layer depths to a .csv file. One csv file is created for each
GPR line. This allows the user to import the data into third-party software for
image generation and further analysis.
If the thickness of a layer cannot be determined because the layers above were
not picked, then those cells are blank.
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After generating a report, a preview is displayed. There are several fields the user can
add information and options to modify the amplitude image map. The Pavement
Structure Report includes:
1. Road name and description including:
a. number of lanes
b. surface material
c. surface condition
d. additional information
2. GPR survey details including:
a. GPR system
b. GPR system configuration
c. type of GPS
3. Overall Pavement Structure Summary listing:
a. Layer Names
b. GPR Velocities
c. Minimum, maximum and average layer thicknesses for all GPR lines
included in the report.
4. Individual GPR line pavement structure report
a. Layer Names
b. GPR Velocities
c. Minimum, maximum and average layer thicknesses for that particular
GPR line.
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Field

Description

Save

Save the current report to an Adobe Acrobat PDF file.

Interactive Chart

Charts of layer thicknesses are interactive. Place the mouse cursor
anywhere on the chart to display the position along the line and depth of
each layer at that position.

3.13.4

Project Position Relationship

The Project Position Relationship defines the relationship between the project
coordinates and a global coordinate system.
The Project Position Relationship menu has 3 options:

This menu is also available in the Project Explorer Right Click menu.
The Wizard takes the user step by step through manually adding global coordinates to a
GPR project data.
Note: The position of Linesets, individual GPR lines or grid lines within the project cannot
be modified by this Wizard.
Auto (GPS based) defines the project-to-global relationship using the GPS files
generated during data collection or manually created and attached.
Undefine removes any previously-defined project-to-global relationship.
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3.13.4.1 Wizard
Use the Wizard option to manually define the relationship between the project (X, Y)
coordinates and the global coordinates (Latitude-Longitude or UTM) of the GPR project
data.
Use the Wizard if:


GPS data were not collected for a GPR data grid but one or two GPS positions in
the grid area are known; GPS positions for the entire grid can be calculated.



The automatic positioning of the grid using GPS files generated during data
collection does not provide an accurate fit to the GPR data grid so you would like
to manually enter GPS positions reference points to provide better positioning of
the grid.

Step 1- Global Position Units

Global Position Units are defined as Latitude-Longitude or UTM (Universal Transverse
Mercator).
1.
2.
3.
4.

Select Latitude-Longitude or UTM. UTM is the default.
If UTM is selected, update the Zone Number field.
If UTM is selected, in the Hemisphere drop-down list, click Northern or Southern.
Select Next.
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Step 2 – Project to Global Transformation – Primary Point
Define a primary X, Y position in the Project coordinate system with a known global
position in UTM or Latitude-Longitude.

1. In the Primary Point fields, enter the project X, Y coordinates for the point where
the global position is known.
The first time you select this option, the Project X, Y position defaults to the
center of all the GPR grid data; this could be the center of one grid or several
grids. If the user manually defines the project X, Y position, the wizard
remembers these values the next time the Wizard is run. Any X, Y point in the
project coordinate system can be entered; X=0, Y=0 is popular.
2. In the Global East or Long field enter the Easting or Longitude Global
coordinates.
In the Global North or Lat field enter the Northing or Latitude Global
coordinates.
UTM Northing and Easting values are always entered in meters and can be positive or
negative.
For example, the UTM values above position the X=0, Y=0 project coordinate point at
Easting = 400567.058 meters and Northing = 3701368.032 in Zone 12 in the Northern
hemisphere.
Latitude and Longitude values are always entered in decimal degrees. Latitudes north
of the Equator are positive (+) values and south are negative (-) values. Longitudes east
of the Prime Meridian (Greenwich) are positive (+) and west are negative (-).
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Step 3 – Rotation Method
The orientation of the project-to-global coordinate relationship can be set in two ways:
1. Rotating using a Y-Axis heading, or
2. Defining the global position of a second point in the project.

Note: if you are simply moving the Primary Point to a new location and not changing the
orientation, select the Finish but before selecting either of the rotation methods
listed.
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Step 4a – Y-Axis Heading
Enter the Y-Axis Heading in degrees from 0 (zero) to 360 degrees. Angles are defined
positive in the clockwise direction, for example, East is 90, South is 180, and West is
270 degrees.

If the project-to-global coordinate relationship is acceptable, click Finish to save the new
settings and exit the dialog.

North=0º

(x=0,y=0)
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Step 4b – Secondary Point
Define a secondary X, Y position in the Project coordinate system with a known global
position in UTM or Latitude-Longitude.

1. In the Secondary Point fields, enter the project X, Y coordinates for a second
point where the global position is known.
The first time you select this option, the Project position defaults to X=0, Y=0 but
any X, Y point in the project coordinate system can be entered.
2. In the Global East or Long field enter the Easting or Longitude Global
coordinates.
In the Global North or Lat field enter the Northing or Latitude Global
coordinates.
UTM Northing and Easting values are always entered in meters and can be positive or
negative.
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For example, the UTM values above position the X=0, Y=0 project coordinate point at
Easting = 400570.150 meters and Northing = 3701376.755 in Zone 12 in the Northern
hemisphere.

Secondary Point
(x=10m,y=7m) = (609801.22 m Easting, 4831943.11m Northing)

(x=0m,y=0m) = (609799.14 m Easting, 4831930.85m Northing)
Primary Point

Latitude and Longitude values are always entered in decimal degrees. Latitudes north
of the Equator are positive (+) values and south are negative (-) values. Longitudes east
of the Prime Meridian (Greenwich) are positive (+) and west are negative (-).
Note: The Primary and Secondary points are used to determine the heading only; the
GPR data does not expand or contract to fit the data from the project coordinates to the
global coordinates. The Primary Point, the heading from Primary to Secondary Point and
the local positioning method used for the survey, typically an odometer, are used to
position the grid in global coordinates.
The Secondary point method is commonly used when GPS positions using a handheld
GPS for two corners of the grid are collected out in the field.
Using GPS Positions from Third-Party Sources
Google Earth is a third-party source to obtain Global positions for the Primary and/or
Secondary Points in the area of your grid. Find the location of the GPR grid in Google
Earth and then use the mouse cursor to find the GPS position for a particular point near
or within the grid. As the mouse cursor is moved around on the image, the global
position is listed on bottom edge.
To obtain better accuracy for points, use the Ruler option in Google Earth to change the
mouse cursor from the default hand to cross-hairs.
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Global positions are entered as UTM or Latitude-Longitude in decimal degrees. Google
Earth usually displays in degrees-minutes-seconds but you can change the Google
Earth display to decimal degrees or UTM under Tools > Options > 3D View Tab >
Show Lat/Long.
Extracting global positions from Google Earth is useful when a GPR grid was collected
along a visible feature such as the edge of a sidewalk, building or road.
Note: while this method ensures the data align with features visible in Google Earth, the
absolute accuracy of the GPS coordinates are only as good as the Google Earth
imagery placement, which can be several meters in some places.
The Google Earth Ruler can also be used to help determine the Y Axis Heading. If the
Ruler function is set to degrees, it displays the Heading in degrees that the Heading
dialog requires.
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3.13.4.2 Auto (GPS-based)
Auto calculates the Project-to-Global coordinate relationship using GPS files in the
project file.
The Auto menu option is most commonly used to restore the original Project-to-Global
relationship after altering it using the Wizard.
Note: it is not recommended to have data in a project widely separated in space. A
warning is displayed if GPS files from different UTM zones are found because the
positional accuracy decreases with increasing separation.
Grids
If a grid of GPR lines were collected with GPS, the Project-to-Global coordinate
relationship is calculated by finding the “best fit” between the known positions of the grid
lines and the GPS positions for those lines. This calculation was automatically done
when the project was opened or the grid was imported into EKKO_Project.
The best-fit calculation minimizes the error between the grid lines and GPS but
depending on the GPS accuracy and the correlation with the grid lines, a manual
adjustment may be necessary in some cases. Use the Wizard option to do this.
GPR Lines
When individual GPR lines in a Lineset are collected with GPS, the raw GPS positions
are used to calculate the Project-to-Global coordinate relationship.

3.13.4.3 Undefine
Undefine removes any previously-defined Project-to-Global coordinate relationship.
When the Project-to-Global relationship is undefined, GPS coordinates are not displayed
on the MapView Status Bar and you cannot generate Google Earth (KMZ) export slice
images to KMZ files for display in Google Earth (to learn more, see the SliceView User’s
Guide).
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Grid Position Relationship

The Grid Position Relationship defines the relationship between the project coordinates
and grids in the project.
The Project Position Relationship menu has 2 options:

This menu is also available in the Project Explorer Right Click menu.
The Wizard takes the user step by step through manually defining the relationship
between the project coordinate and the grid coordinate systems.
Note: The position of Linesets, individual GPR lines or grid lines within the project cannot
be modified by this Wizard.
Auto (GPS based) defines the grid-to-project relationship using the GPS files generated
during data collection or manually created and attached. It is not accessible if there is
no Project-to-Global relationship defined.

3.13.5.1 Wizard
Use the Wizard option to manually position a grid in the project coordinate system.
Step 1 – Primary Point
Define a primary X, Y position in the grid coordinate system to define in the Project
coordinate system.

1. In the Primary Point fields, enter the project X, Y coordinates for the grid point.
Select a grid point with the realization that any possible rotation of the grid is
about this point.
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The Project position defaults to the XY position of the center of the grid if a
Project-to-Global relationship has been defined by GPS files; otherwise, it
defaults to X=0, Y=0. Any X, Y point in the grid coordinate system can be
entered.
2. In the Project Points field, enter the project X, Y coordinates for the primary point.
For example, the values above position the X=0, Y=0 grid coordinate point at project
coordinate X=10, Y=10.
Step 2 – Rotation Method
The orientation of the grid can be set in two ways:
1. Rotating using a Y-Axis heading, or
2. Defining the project position of a second point in the grid.

Note: if you are simply moving the Primary Point to a new location and not changing the
orientation, select the Finish but before selecting either of the rotation methods
listed.
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Step 3a – Y-Axis Heading
Enter the Y-Axis Heading in degrees from 0 (zero) to 360 degrees. Angles are defined
positive in the clockwise direction, for example, East is 90, South is 180, and West is
270 degrees.

Enter the rotation angle and click Finish to save the new settings and exit the dialog.
For example, the two steps above moves the x=0, y=0 point of the grid to project
position x=10, y=10 and the grid is rotated 45 degrees clockwise around the x=10, y=10
point.

105

EKKO_Project User’s Guide

EKKO_Project Interface

Step 3b – Secondary Point
Another way of rotating the grid is by defining the project position of a second point in
the grid. .

1. In the Secondary Point fields, enter the project X, Y coordinates for the grid point.
Select a point with the realization that the grid will rotate based on the direction
from the first point to the second point. Any X, Y point in the grid coordinate
system can be entered.
2. In the Project Points field, enter the project X, Y coordinates for the secondary
point.
Click Finish to save the new settings and exit the dialog.
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For example, the two steps above moves the x=0, y=0 point of the grid to project
position x=10, y=10 and the grid is rotated based on secondary grid point x=5, y=5
moving in the direction of project position x=20, y=10.

Note: The Primary and Secondary points are used to determine the heading only; the
GPR grid does not expand or contract to fit the data from the grid coordinates to the
project coordinates. The Primary Point, the heading from Primary to Secondary Point
and the local positioning method used for the survey, typically an odometer, are used to
position the grid in project coordinates.

107

EKKO_Project User’s Guide

EKKO_Project Interface

Positioning Multiple Grids
The grid positioning methods shown above can be used to place more than one grid into
the correct spatial location in the project space.

3.13.5.2 Auto (GPS-based)
Auto calculates the Grid-to- Project coordinate relationship using GPS files in the project
file.
The Auto menu option is most commonly used to restore the original Grid-to- Project
relationship after altering it using the Wizard.
Auto is only accessible if a Project-to-Global relationship has been defined by GPS files.
Note: it is not recommended to have data in a project widely separated in space. A
warning is displayed if GPS files from different UTM zones are found because the
positional accuracy decreases with increasing separation.
Grids
If a grid of GPR lines were collected with GPS, the Grid-to- Project coordinate
relationship is calculated by finding the “best fit” between the known positions of the grid
lines and the GPS positions for those lines. This calculation was automatically done
when the project was opened or the grid was imported into EKKO_Project.
The best-fit calculation minimizes the error between the grid lines and GPS but
depending on the GPS accuracy and the correlation with the grid lines, a manual
adjustment may be necessary in some cases. Use the Grid Position Relationship
Wizard option to do this.
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Process

Use the optional Processing module to edit and process GPR lines using various
functions including repositioning, temporal and spatial filters, and migration.
Processing is applied to any checked GPR lines. If no GPR lines are checked,
processing is applied to the selected GPR line.
Note: Selecting (not checking) a GPR line and then using the Project Explorer rightclick menu for processing only processes the selected line regardless of whether any
other lines are checked.
It is a best practice to make a copy of the GPR Lineset, grid or lines and then apply the
processing to the copy of the GPR lines. While processing can always be undone, this is
a good way to plot both the original data and the processed data to compare the effects
of the processing.

Figure 13: Files to be processed must be checked before selecting Process.
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1. To open the Processing window, click Tools > Process:

Figure 14: The Processing dialog lists available processing for GPR lines.

The Available Processes pane lists all processes that you can add to your Recipe.
2. To add a process to your recipe, in the Available Process pane, select the process.
To expand the processes list, click the + sign.
3. Click the selection arrow

.
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When a process is selected, a description is displayed on the bottom of the dialog.
Detailed descriptions of every process are provided in Processing Functions.

Figure 15: Processes added to the Recipes pane.

4. Repeat step 3 until you have added all the processes you want to add to your recipe.

3.13.6.1 Input Parameters
Most processes require one or more input parameters. When a process is selected in
the Recipe pane, the parameters are listed in the Process Parameters pane.
1. To modify a process value, click the drop-down arrow.
2. Click a value.
For most numerical parameters, a new value can be entered by clicking the current
value and then entering the new value.

3.13.6.2 Applying Processing
Once you have completed processing, click Process Line(s) to apply the processing to
the selected GPR line(s).
The list of GPR lines is updated in Project Explorer to display the GPR lines that have
been processed (indicated by a small letter “p” beside the file - Figure 4).

3.13.6.3 Deleting a Process
1. To delete a process, from the Recipes pane click the process you want to remove.
2. Click the Delete

.
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3.13.6.4 Save Recipe
A Recipe is a set of processing operations that can be saved and used again on other
projects. Creating Recipes allows you to reuse common processes or compare different
data sets using the same processing.
1. To save the selected processes to your Recipes, in the Recipes pane, click Add
Recipe to my Recipes
2. In the Create New Recipe dialog box, enter a name for the recipe.

3. Click OK.
Once saved, the recipe is available in the My Recipes drop-down.
Any recipe can be edited, saved, and renamed as another recipe.

3.13.6.5 Load Recipe
Once a recipe has been saved, you can access it by clicking the My Recipes drop-down
list above the Recipe pane.
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3.13.6.6 My Recipe Management
1. To open your recipe list, in the Processing window, click the ellipsis icon
the My Recipes drop-down.

beside

2. Use the following table as a guide to working with the My Recipes dialog box.
Field
Delete

Description
1 In the text area, select the recipe you want to remove.
2 Click Delete.
3 In the confirmation dialog box, click Yes.

Rename

1 To change the name of a recipe, click the recipe name.
2 Click Rename.
3 In the Rename Recipe dialog box, type the new recipe name.
4 Click OK.

Import

1 To bring a recipe file in to your recipe file, click Import.
2 In the Open dialog navigate to, and then select the file you want to
import.
3 Click Open.

Export

1 To send a recipe to another EKKO_Project user, select the recipe.
2 Click Export.
3 In the Save As dialog box, save the file.

Note: Imported and exported recipes are saved as a .json files.

3.13.7

Undo Process

1. To undo processing click Tools > Undo Process.
This resets processed GPR lines to their original state before processing was applied
to them or to their processing state when they were copied.
When a line is copied, its current processing is permanent and cannot be undone.
2. In the confirmation dialog box, click Yes to undo the processing.
Otherwise, click No.
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Merge Lines

Sometimes during data acquisition, a long, continuous GPR survey line is broken up into
two or more pieces and saved as separate lines. Merge Lines is used to combine the
data from two or more GPR lines into a single, separate line.
In Project Explorer, check the GPR lines to be merged and then select Tools > Merge
Lines.
A dialog allows the merge order of the lines to be changed by selecting the line name
and pressing the Up or Down buttons to move the line in the list.
The name of the merged line defaults but can be edited.

Press OK to create the new merged line. If all the lines came from the same folder, the
new, merged line is saved to that folder. If the lines came from different folders, the
new, merged line is saved in a new lineset folder.
If the merged line name conflicts with a line name already in the project, the new line is
automatically appended with (2), (3) etc.
Some of the restrictions/features of Merge Lines are:
1. Lines cannot be merged together if any of the following survey parameters differ:
a. Survey Type
b. Frequency
c. Time Sampling Interval
d. Step Size
e. Antenna Separation
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2. If the lines differ in Time Window length the merges the lines using the longest
time window, padding data onto the bottom of lines with shorter time windows so
no data is ever lost.
3. If lines have a different First Break point number the largest first break point
number from all the lines is used and other lines are padded at the top so that no
data is lost during the merge operation.
4. Traces are not shifted for differences in the First Break values between lines. It is
best to run the Repick First Break routine for each line before merging or on the
merged line so the first break is consistent for the new merged line.
5. The Start Position of the new merged line is the same as the Start Position of the
first line in the merge list.
6. The number of Stacks of the new merged line is the same as the number of
Stacks of the first line in the merge list.
7. Lines with interpretations can be merged.
A list of lines used to create a merged line can be seen by selecting the line in the
Project Explorer, and then selecting the Acquisition tab and expanding Additional
Info.

3.13.9

GPS

The Survey Line offset and Latency time are used to determine which part of the
recorded GPR section correlates to a given GPS position.

3.13.9.1 Latency
The GPS latency time is the time difference between when the GPS receiver obtains its
position and when it logged by the DVL. If GPS latency time is not corrected for, the
GPS position of targets and features of interest in the GPR line is less accurate.
GPS latency is not a large problem when GPR data are collected on slow-moving
platforms such as the SmartCart or SmartTow; it has the largest effect when trying to
determine the true position of a fast-moving platform such as the SmartChariot.
For example at 25 kph, you are moving 6.94m per second. If the GPS has 1.00 second
latency, your data position would be off by 6.94m. Further, if you also collect data in
opposite direction (i.e. north and south adjacent lanes) the positional offset on a linear
target such as a buried utility that spans both lanes would be off by 6.94 x 2 = almost
14m.
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The latency time will vary by GPS, and data logger hardware/software and can be
calculated and input in this dialog.
See Appendix C: GPS Latency Procedure for calculating the GPS latency time for your
system.

3.13.9.2 Offset
Offset defines the X, Y and Z offset distances between the center of the GPR system (or
antennas, if using a low frequency) and the GPS. These distances are necessary to
correct the position of the GPS if it is offset from the GPR.

This option displays a diagram that defines the co-ordinate system for the GPS X, Y and
Z offset values.
Lateral (X)
X (or Lateral) is the distance, left or right of the survey line direction, from the GPR to the
GPS Antenna. Looking in the survey line direction, the distance is positive if the GPS
receiver is to the right of the GPR and negative if it is to the left of the GPR.
Survey Line (Y)
Y (or Survey Line) is the distance from the GPR to the GPS receiver in the survey line
direction. The distance is positive if the GPS receiver is ahead of the GPR and negative
if it is behind the GPR.
Height (Z)
Z (or Height) is the height of the GPS receiver above the GPR.
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Example
When a GPR system collects data using a SmartChariot, the GPS is offset +0.50 meters
in the Survey Line (Y) direction and +0.50 meters in height (Z).
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3.14 Window Menu
To open the Window menu drop-down list, click Window:

3.14.1

Open Line Preview

If the Line Preview window was closed, it can be opened by selecting Window > Open
Line Preview.

3.14.2

Open MapView

If the MapView window was closed, it can be opened by selecting Window > Open
MapView.

3.14.3

Tile Horizontally

Selecting Window > Tile Horizontally will arrange the Line Preview and MapView
windows so they are tiled horizontally in the space between the other windows open on
the screen.

3.14.4

Tile Vertically

Selecting Window > Tile Vertically will arrange the Line Preview and MapView
windows so they are tiled horizontally in the space between the other windows open on
the screen.
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3.15 Help Menu
To open the Help menu drop-down list, click Help:

3.15.1

About EKKO_Project

This option displays the EKKO_Project version number, a description, and ownership
information.

3.15.2

EKKO_Project User’s Guide

Select this option to open this document in PDF.
Adobe Acrobat Reader must be installed on your PC to open this document. If not, you
can download it from Adobe.

3.15.3

Restore Factory Defaults

Click Restore Factory Defaults to reset all the windows, dockable windows, menus,
and toolbars to their default values.
Note: Restoring automatically closes EKKO_Project, so you must save your project
first, and then re-open EP for the restoration to take effect

3.15.4

EKKO_Project and Module Registration

The Product Registration dialog allows you to enter a License Key, request a License
Key, request a trial License Key or transfer a License to a different computer.
For more details see the System Documentation and Software Installation
document.

3.15.5

Contact Us

Displays contact information for Sensors & Software including mailing address, email
addresses, website, and phone and fax numbers.
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4 Window Operations
EKKO_Project can display multiple panes on the main screen, but only one pane can be
active and accept changes at one time.

4.1

Resizing the EKKO_Project Window

If an EKKO_Project pane is not maximized (full screen), you can resize it by clicking and
dragging any frame or corner to the size you require.

Figure 16: Click and drag a Project Explorer or Properties window to change its dimensions.

Note: As the size of the window changes, the information in the window will distort to
fit the window size. If the window is made too small, the pane may close completely;
click and drag the frame to re-open it.

4.2

Undocking and Docking Windows

1. To undock the Project Explorer and Properties panes from the edge of the screen,
click and drag the window’s title banner.
2. Drop the window at any location, or dock it on any edge of EKKO_Project.
Arrow icons (
) appear on the screen to indicate where (top, bottom, left, or right
edge) the pane can be docked.
3. Drag the title banner to the icon and drop the window to dock it in the indicated
position.
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Note: It is a best practice to dock windows.

Figure 17: Example of moving the Project Explorer. Note the docking arrows.

4.3

Pinning Windows

To pin a docked Project Explorer or Properties pane to the side of EKKO_Project, in the
pane’s title bar, click the Pin icon ( ).

Figure 18: Example of pinning a window
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To expand these panes to their original size, click the pane and then click the pin
icon to pin the window back into position.

4.4



Window Operations

Closing a Window

To close a window, press close ( )
To reopen a closed window, in the menu bar, click View > Toolbars and Docking
Windows

4.5

Adding or Removing Buttons from
Toolbars

Use the Add and Remove buttons to edit the toolbars.

4.5.1

Standard Toolbar

1. To manage what appears in the Standard toolbar, click the drop-down arrow beside
the Help icon

.

2. Click Add or Remove Buttons > Standard.

3. To display an icon in the Standard toolbar, click beside the button to display
checkmark icon.
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Window Operations

To restore the Standard toolbar to the factory default settings, click Reset Toolbar.
To tailor the Standard toolbar to better suit your need, click Customize > Toolbars
tab.

4.5.2

View Control Toolbar

1. To manage what appears in the View Control toolbar, click the drop-down arrow
beside the Export View to File icon

.

2. Click Add or Remove Buttons > View Control.

3. To display an icon in the View Control toolbar, click beside the button to display
checkmark icon.



To restore the View Control toolbar to the factory default settings, click Reset
Toolbar.
To tailor the View Control toolbar to better suit your need, click Customize > >
Toolbars tab.

124

EKKO_Project User’s Guide

Processing Functions

5 Processing Functions
This section lists the details of the processing functions available in the optional
Processing module.

5.1

Attributes

Note: If you are unfamiliar with Attributes, you should refer to an outside reference as
only a brief overview is given in this document. For example, Yilmaz, O., 1987,
“Seismic Data Processing; Investigations in Geophysics No. 2: Society of Exploration
Geophysicists.”
While we normally only plot and interpret the real part of a complex-valued signal, the
imaginary (or quadrature) component can be used to reveal some useful information
about the signal. These attributes, usually called 'instantaneous attributes', include
instantaneous amplitude (or trace envelope), instantaneous phase, and instantaneous
frequency.
If a complex trace is given by:
𝑧(𝑡) = 𝑥(𝑡) + 𝑖𝑦(𝑡)
where 𝑥(𝑡) is the real component of the trace
and 𝑦(𝑡) the imaginary component of the trace
Instantaneous Amplitude (or Trace Envelope) is given by:
𝑒(𝑡) = (𝑥 2 (𝑡) + 𝑦 2 (𝑡))1/2
Instantaneous Phase is given by:
𝑦(𝑡)
𝜙(𝑡) = atan(
)
𝑥(𝑡)
Since Instantaneous Frequency is the derivative of Instantaneous Phase, it is given by:
1 𝑑𝜙
1 𝑦 ′ (𝑡)𝑥(𝑡) − 𝑦(𝑡)𝑥 ′ (𝑡)
𝜔(𝑡) = ( )
=( )∙
2𝜋 𝑑𝑡
2𝜋
𝑥 2 (𝑡) + 𝑦 2 (𝑡) + 𝜀
where 𝑥 ′ (𝑡) And 𝑦 ′ (𝑡) are calculated using central differences:
𝑥 ′ (𝑡) =

𝑥𝑖 +1−𝑥𝑖 −1
2∆𝑡

and 𝑥 ′ (𝑡) =

𝑦𝑖 +1−𝑦𝑖 −1
2∆𝑡

and 𝜀 is a constant value (defined as 1) to increase the stability of the function by
preventing division by zero.
Since these attributes can only be calculated using the imaginary component of the
complex trace, it is necessary that it be obtained before processing the data. This is
done automatically in the Envelope, Instantaneous Phase, and Instantaneous Frequency
routines using the Hilbert Transform
method. Basically, this method uses a time convolution approach to find the imaginary
part of the trace.
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Envelope

The basic idea behind enveloping a trace is to convert the trace from a wavelet with both
positive and negative components to a monopulse wavelet with all positives. The
process removes the oscillatory nature of the radar wavelet and shows the data in its
true resolution. This process can also simplify the display of a radar section making it,
perhaps, easier to interpret.
The mathematical definition of instantaneous amplitude is shown above. The
instantaneous amplitude outlines the envelope of the trace. It is independent of phase,
that is, it may have its maximum at points other than the peaks and troughs of the real
trace, especially where an event is the composite of several reflections. While it is often
referred to as reflection strength, some believe that this term places a dubious
interpretational assumption on the true meaning of instantaneous amplitude. They
suggest that the envelope of a trace is simply an interpretational tool that describes
waveform shape. Interpretation is aided by comparing the constancy of reflection
character.
Envelope Parameters
Window Width

Is the width of the filter in pulse widths.
The default value is 1.0 pulse widths.

5.1.2

Instantaneous Frequency

The mathematical definition of instantaneous frequency is shown above; it is used as a
correlation tool. The frequency character of an event will change as the lithology
changes, the thickness changes or at interfaces such as gradational boundaries, pinchouts and the water table.
Instantaneous Frequency Parameters
Window Width

The width of the filter in pulse widths.
The default value is 1.0 pulse widths

Epsilon

Enhances the stability of the result for small signals
The default value is 1.0 millivolt

5.1.3

Instantaneous Phase

The mathematical definition of instantaneous phase is shown above. It is used to
emphasize the continuity of events. Since phase is independent of the trace envelope, it
can often make weak coherent events more prominent, even events that interfere with
one another. Instantaneous phase is always measured between -π and +π and
therefore data tends to have a saw-tooth appearance.
The instantaneous phase is multiplied by amplitude/epsilon if amplitude <= epsilon. This
drives the instantaneous phase towards zero for amplitudes smaller than epsilon.
If the amplitudes have a DC offset that place it near a zero imaginary component and a
slightly negative real component, +/-pi phase cross over can occur and data will appear
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noisy. Removing DC bias using DEWOW is recommended to so that epsilon will remove
this problem.
Instantaneous Phase Parameters
Window Width

The width of the filter in pulse widths.
The default value is 1.0 pulse widths

Epsilon

Enhances the stability of the result for small signals
The default value is 1.0 millivolt

5.2

Filters – 2D

5.2.1

Migration

The migration process applies a synthetic aperture image reconstruction process to the
GPR line. It uses a 2D FFT Stolt migration operator to migrate a common offset GPR
section.
The process collapses GPR hyperbolic responses from point-like targets back into a
point. Hyperbolic shape is dictated by the ground velocity so migration requires the input
velocity to be as accurate as possible. If the velocity is too low, the data will be undermigrated with the hyperbola not fully collapsed.
If the velocity is too high, the data will be over-migrated with hyperbolas inverted into
smile shapes. The optimal velocity can be determined by experimentation or measured
using the Hyperbola Velocity Calibration tool in LineView.
Migration Parameters
Velocity

Radar velocity to use in the synthetic aperture process.
Must be 0.01 to 0.30 meters/nanosecond or 0.03 to 0.98
feet/nanosecond.
Typical velocities of ground materials are 0.06 to 0.15 m/ns (0.20 to
0.49 ft/ns).
The default value is 0.1 m/ns (0.328 ft/ns).

The migration process will fail if the First Break Offset time is negative (to learn more,
see the Acquisitions tab).

5.3

Filters – Spatial

Spatial filters act on radar data in the spatial (or position) direction. These filters use
adjacent traces during the filtering procedure. They alter the shape of the trace through
various mathematical manipulations designed to enhance or eliminate certain features.
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Background Average Subtraction

Background Average Subtraction is used to subtract the average trace of the entire GPR
line from every trace in the line.
This process has the effect of enhancing dipping events (like hyperbolas from point
targets) and removing horizontal responses common to all traces in the line. It is
commonly used to remove the direct air and direct ground waves (also known as the
transmit pulse) visible at the top of the line. It will also remove horizontal bands in the
data present throughout the length of the line.
The average trace is calculated by adding all the traces in the line together and dividing
by the total number of traces. This average trace is then subtracted from each trace in
the line.
Background Average Subtraction is similar to the Background Subtraction routine below,
but, because it averages over the full width of the GPR line, rather than a shorter length
typically used with that routine, it tends to be less severe in its removal of horizontal
events. The more traces used in the Background Subtraction Filter Width parameter, the
more localized horizontal features remain in the data.
Background Average Subtraction Parameters
There are no input parameters necessary to run this process.

5.3.2

Background Subtraction

Background Subtraction is used to apply a running-average background subtraction to
the data set.
This process has the effect of enhancing dipping events (like hyperbolas from point
targets) and suppressing or completely removing horizontal responses. This can be very
useful for removing localized flat-lying events.
A window of traces with a width defined by the Filter Width parameter is averaged with
a weighted average (see below) and the result is subtracted from the trace in the center
of the window. The window moves along one trace and the process is repeated.
To illustrate the processing, consider the case of a GPR line collected with a step size of
0.1 meters. If a Filter Width of 0.5 meters is chosen, the operation works on a window of
5 traces at a time. When the routine processes trace number 9, it reads traces 7, 8, 9,
10, and 11, finds the average of the five traces, subtracts that average trace from the
original trace 9 and saves the resultant in place of trace 9. It then moves over one trace
to trace 10, averages traces 8, 9, 10, 11 and 12, subtracts the average trace from the
original trace 10 and saves the resultant as trace 10, and so on.
The more traces used in the background subtraction process, the more flat-lying
reflections will remain in the data. For example, setting the Filter Width to 2 meters
removes any local flat-lying reflections 2 meters long or longer. Flat-lying reflectors less
than 2 meters long will remain in the data line, although their amplitudes may be
reduced.
To remove all flat-lying events from data, set the Filter Width to a distance equal to two
times the step size.
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Choosing a Filter Width as large as or larger than the line will remove the average trace.
Signal from line data, similar to the Background Average Subtraction process described
above.

a

c

b

Figure 19: Filter types for the Background Subtraction Filter. (a) Rectangular, (b) Triangular (c) BlackmanNuttall

The Filter Type dictates the weighting the traces on the edges of the Filter Width have
on the calculation of the average trace.




Rectangular filter type uses equal weighting to all traces
Triangular filter type applies more weight to the trace in the center of the window
and linearly less to the traces moving out from the center to the edges of the
window
Blackman-Nuttall filter type applies more weight to the trace in the center of the
window and less to the traces on the edges of the window but uses a shape
similar to a Gaussian curve (Figure 19)

Background Subtraction Parameters
Filter Width

The width of the running-average window added together in the
spatial trace-differencing filter.
If the filter width is greater than the length of the GPR line, a filter
width equal to the length of the line is used.
The default value is 1 meter.

Type

The shape of the filter used to calculate the running-average
trace.
Options are Rectangular, Triangular or Blackman-Nuttall.
The default is rectangular.

5.3.3

Horizontal

Horizontal applies a running average filter horizontally along a GPR line. It replaces each
trace with an average trace produced by averaging adjacent traces together. Its primary
purpose is to emphasize flat-lying or slowly dipping reflectors while suppressing rapidly
changing ones (i.e. hyperbolic tails or random noise).
A window of traces with a width defined by the Filter Width parameter is averaged and
the resultant replaces the trace in the center of the window. The window moves along
one trace and the process is repeated.
To illustrate the processing, consider the case of a GPR line collected with a step size of
0.1 meters. If a Filter Width of 0.3 meters is chosen, the operation works on window of 3
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traces at a time. When the routine processes trace number 5, it reads traces 4, 5, and 6,
finds the average of the three traces and uses the average trace in place of trace 5. It
then does the same thing with trace 6, and so on. If the number of traces to average is
even, then the extra trace is taken from the 'left' side, i.e. from the lower trace number.

5.4

Filters - Time

5.4.1

Bandpass Filter

Bandpass filtering is used when the GPR signal is contained in a defined band of
frequencies and there is "noise" energy in the remainder of the spectrum. By bandpass
filtering, the desired signals can be enhanced at the expense of the out-of-band noise.
Bandpass is designed around the use of Fourier transform filtering concepts.
The use of Fourier transform-based filtering is quite common in the geophysical realm
and many texts and papers describe the concepts very well. The following briefly
outlines the processing, how it is implemented, and the side effects that improper
application of the filter may induce.
Each GPR trace is a time series which can be viewed as being composed of a
superposition of sinusoidal signals. With a Fourier transform based filter, a GPR trace is
decomposed into its spectral (sinusoidal) components through a Fourier transformation
algorithm, the spectral amplitudes multiplied by the filter transfer function, and the
resultant spectrum is inverse Fourier transformed to create the filtered GPR trace.
Filtering is restricted to zero phase bandpass filtering. To describe the transfer function
of a bandpass filter one has to define its lower and upper cut-off frequencies. In addition,
the sharpness of the cut-off at either end of the pass band must be quantified.
The transfer function of the filter is characterized by four frequencies, fc1, fp1, fp2, and
fc2. The filter has zero amplitude at all frequencies below fc1 and above fc2. In the pass
band between frequencies fp1 and fp2, the filter has unit amplitude. Between fc1 and fp1
and fp2 and fc2, the transition from zero amplitude to unit amplitude is a cosine curve
that gives a smooth transition.
The most efficient way of Fourier transformation is to exploit the Fast Fourier Transform
(commonly referred to as the FFT) algorithm. The FFT algorithm is based on the
assumption that the times series being processed is one cycle of an infinitely recurring
signal. While this is not strictly true, by extending a finite time series with zeros and
tacitly assuming periodicity, one can use the FFT algorithm with impunity to carry out a
periodic convolution operations. Bandpass uses this approach.
Bandpass Filter Parameters
The parameters needed for this application are:
fc1

Lower cut-off frequency.
Frequencies below this value are completely removed from the GPR
line.

fp1

Lower pass band frequency.
Frequencies below this value taper to zero at the fc1 frequency.
Frequencies above this value to the fp2 value are retained in the GPR
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line.
fp2

Upper pass band frequency.
Frequencies below this value to the fp1 value are retained in the GPR
line.
Frequencies above this value taper to zero at the fc2 frequency.

fc2

Upper cut-off frequency.
Frequencies above this value are completely removed from the GPR
line.





Frequencies must be ascending order and it is suggested that the slope of the high
frequency side be less steep than the slope of the low frequency side to minimize
filter artifacts on the data.
All frequencies are entered as a percentage of the antenna center frequency.
Default frequencies are 40%, 80%, 120% and 160% of the antenna center
frequency.
Average Frequency Spectrum plots can be used to help determine filter parameters.

5.4.2

DC Removal

While the Dewow process below automatically removes any low frequency “wow” from
the data, sometimes it may be desirable to perform a DC removal on the data in addition
to, or instead of DEWOW. For example, tests have shown that a DC removal applied to
high frequency radar data (> 200 MHz) rather than a Dewow correction may be more
effective in reducing correction artifacts.
DC Removal is used to remove a DC level from all the traces in the GPR data line(s).
The DC level to be removed can be manually input by the user or automatically
calculated by the program.
With an input DC level, the value is subtracted from all the points in all the traces in the
data set.
If DC_SHIFT calculates the DC level to be removed, it calculates a new DC level for
each trace in the GPR line. This is done by taking all points in each trace and calculating
a DC level for that trace. This value is then subtracted from each point in the trace. This
process is repeated for each trace in the data set. Typically, traces will have
approximately the same DC shift in a given GPR line.

5.4.3

Dewow

In most cases when processing GPR data, it is recommended that Dewow be applied to
the GPR line before any other processing steps.
Depending on the proximity of the GPR transmitter and receiver as well as the electrical
properties of the ground, the transmit signal may induce a slowly decaying low frequency
"wow" on the trace which is superimposed on the high frequency reflections.
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a

b

Figure 20: (a) Raw GPR trace with WOW. (b) GPR Trace with WOW removed using DEWOW.

All GPR data contains a low frequency component. The magnitude of the low frequency
component and how it manifests itself in the data depends on the ground conditions
around the antennas and the distance between the transmitter and receiver. In general,
the low frequency component of the GPR signal does not propagate but diffuses into the
ground. In other words, the lower end of the spectrum sees an inductive (eddy current)
type response as opposed to a propagating (displacement current) type response.
The result is that the large transmit pulse emitted by the radar can be followed by a
slowly decaying transient, commonly called “wow”.
With this wow usually present, it is common practice that GPR data be high pass
(Dewow) filtered. In fact, LineView and other GPR line display software automatically
applies Dewow before plotting the data. Users are often unaware of the wow or low
frequency component in the data. The raw data, however, always retains this
information.
Dewow is designed to remove this unwanted low frequency while preserving the high
frequency signal. The removal of this wow in the data is also called the "signal saturation
correction".

Figure 21: (Left) Raw GPR line with WOW. (Right) GPR line with WOW removed using DEWOW.
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The wow is removed from the data by applying a running average filter down each trace.
A window with a width of 1.33 pulse widths at the nominal frequency is set on the trace.
The average value of all the points in this window is calculated and subtracted from the
central point. The window is then moved along the trace by one point and the process is
repeated.

5.4.3.1

Dewow Artifacts

While any filter produces unwanted artifacts in the data to which it is applied, Dewow is a
good compromise filter.
The Dewow filter can induce two types of artifacts into the plotted data sections. The first
is a pre-cursor to the onset of a pulse (Figure 22: DEWOW artifacts: signal precursor.Figure 22). When the original data are high pass filtered the wavelet is stretched
in time with additional oscillations occurring before and after the original pulse. This is
what gives rise to a pre-cursor in the data before the first break on plotted GPR lines.

Figure 22: DEWOW artifacts: signal pre-cursor.

The second artifact is caused by electronic clipping. The basic concept is depicted in
Figure 23.
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Figure 23: DEWOW artifacts: electronic clipping

The original signal which is acquired by the antenna and presented to the receiver
electronics looks like that sketched in Figure 23 a. The radar electronics clip any signals
above the 50 millivolt level. Figure 23 b shows the type of result that will be measured if
clipping occurs in the signal pre-conditioning circuitry. When these data are finally high
pass filtered, a blank zone in the area where the original signal had a large wow above
the clipping level of the electronics can appear. This results in a blank section on the
record with no reflections visible (Figure 23 c). The user must be aware that this can
occur in some geologic settings and the antenna spacing should be increased to reduce
the wow signal amplitude below the clipping level of the receiver electronics.
Dewow Parameter
Window Width

is the width of the filter in pulse widths
The default value is 1.33 pulse widths.

5.4.4
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DynaT

Dynamic Target enhancement (DynaT) allows users to preferentially enhance the
response from targets of different sizes – small, medium and large. GPR users usually
use signal amplitude to discern targets and small targets can be difficult to see in GPR
data because they always produce smaller amplitude responses than larger targets.
The DynaT process exploits the fact that the frequency content of the returned signal
varies with target size. The rate of change of signal amplitude with size varies especially
strongly for small targets. Using the ultra-wideband frequency content inherent in the
GPR signals generated by Sensors & Software GPR systems, DynaT differentiates the
frequency-dependent GPR target responses to enhance the amplitude of targets based
on relative size.
DynaT is optimized for GPR data with a 250 MHz center frequency. The GPR lines to
be processed with DynaT must be 250 MHz data.
DynaT Parameter
Target Size

The relative size of the target to enhance – Small, Medium or
Large
The default value is Medium.

5.4.6

Highpass

The highpass temporal filter removes frequencies below a cut-off frequency. It is useful
for removing low frequency content in the GPR data; it is sometimes used instead of the
Dewow filter.
High Pass is a recursive filter designed for filtering of a GPR line in the time domain. It is
an infinite impulse response zero phase filter.
The typical frequency domain characteristics of the filter are as shown below.

The filter requires the input of the cut off frequency. Frequencies between 10% and 90%
in 10% increments of the Nyquist frequency can be input.
The Nyquist frequency is determined from the Time Sampling Interval for the GPR
line; these values are listed in the Advanced category of the Acquisition tab.
FNyquist = 1/(2 * time sampling Interval X 10-6)
Where:
the Nyquist frequency is in MHz and
The time sampling interval is in picoseconds (ps)
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If the default temporal sampling intervals are used when collecting data, the Nyquist
frequencies for each antenna frequency are listed in the following table:
Antenna Frequency (MHz)

Temporal Sampling Interval
(ns)

Nyquist Frequency (MHz)

12.5

6400

78

25

3200

156

50

1600

313

100

800

625

200

400

1250

250

400

1250

500

200

2500

1000

100

5000

Highpass Parameter
Cut-off Frequency
Percent

The cutoff frequency is a percentage of the Nyquist frequency in
10% increments from 10%-90%.
Frequency above which data is preserved and below which data
is removed.

For example, if the Nyquist frequency is 625 MHz, the possible cutoff frequencies are:
10% = 62.5 MHz
20% = 125 MHz
30% = 187.5 MHz
40% = 250 MHz
50% = 312.5 MHz
60% = 375 MHz
70% = 437.5 MHz
80% = 500 MHz
90% = 562.5 MHz
Note: The Average Frequency Spectrum plot extends from 0MHz up to the Nyquist
frequency.
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Lowpass

The low pass filter removes frequencies above a cut-off frequency. It is useful for
removing high frequency noise in the GPR data.
Low pass is a recursive filter designed for filtering of a GPR line in the time domain. It is
an infinite impulse response zero phase filter.
The typical frequency domain characteristics of the filter are as shown below.

The filter requires the input of the cut off frequency. Frequencies between 10% and 90%
in 10% increments of the Nyquist frequency can be input.
The Nyquist frequency is determined from the Time Sampling Interval for the GPR
line; these values are listed in the Advanced category of the Acquisition tab.
FNyquist = 1/(2 * time sampling Interval X 10-6)
Where:
the Nyquist frequency is in MHz and
The time sampling interval is in picoseconds (ps)
If the default temporal sampling intervals are used when collecting data, the Nyquist
frequencies for each antenna frequency are listed in the following table:
Antenna Frequency (MHz)

Temporal Sampling Interval
(ns)

Nyquist Frequency (MHz)

12.5

6400

78

25

3200

156

50

1600

313

100

800

625

200

400

1250

250

400

1250

500

200

2500

1000

100

5000
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Low Pass Parameters
Cut-off Frequency
Percent

The cutoff frequency is a percentage of the Nyquist frequency in
10% increments from 10%-90%.
Frequency above which data is preserved and below which data
is removed.

For example, if the Nyquist frequency is 625 MHz, the possible cutoff frequencies are:
10% = 62.5 MHz
20% = 125 MHz
30% = 187.5 MHz
40% = 250 MHz
50% = 312.5 MHz
60% = 375 MHz
70% = 437.5 MHz
80% = 500 MHz
90% = 562.5 MHz

5.4.8

Vertical

The Vertical Filter is used to apply a running average filter vertically (down the trace) on
a GPR line. The signal is averaged by replacing the data value at a given point by the
average data value over a window centered about that point. Its primary purpose is to
reduce random or high frequency noise by acting as a low pass temporal filter.
A window of pulse widths defined by the Filter Width parameter is averaged and the
resultant replaces the trace in the center of the window. The window moves along one
trace and the process is repeated.
To illustrate the processing, consider the case of a GPR line collected with an antenna
frequency of 100 MHz and a time sampling interval of 800 picoseconds:
Pulse width = 1500 / (frequency * (time sampling interval/1000))
= 18 points.
If a Filter Width of 0.2 pulse widths is chosen, the operation works on a window of 3
sample points at a time. When the routine processes point number 5, it reads points 4, 5,
and 6, finds the average of the three points and uses the average value in place of point
5. It then does the same thing with point 6, and so on. If the number of points to average
is even, then the extra trace is taken from the left' side, i.e. from the lower trace number.
The more pulse widths (points) used in the Vertical filter, the more high-frequency data
will be removed from the data. Typical values for the number of pulse widths in the filter
are 0.1 to 1.
Antenna Frequency (MHz)

Temporal Sampling Interval
(ns)

Pulse width (pts)

12.5

6400

18

25

3200

18

50

1600

18

100

800

18
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200

400

18

250

400

15

500

200

15

1000

100

15

The following example calculates how to determine how many pulse widths to use in the
averaging window.
To filter high frequency noise that's affecting your data:
1. Estimate the length (in nanoseconds) of the noise from a plot of the GPR line (Trace
Plot and Average Trace Amplitude can be helpful).
2. Select a typical noise cycle from the section and then measure the peak-to-peak or
trough-to-trough time length.
3. Divide this number by the time sampling interval in nanoseconds.
The Time Sampling Interval for the GPR line is listed in picoseconds in the
Acquisition tab’s Advanced category.
4. Divide by 1000 to calculate it in nanoseconds.
The result is the length of the noise cycle in points (round up to the nearest whole
number if necessary).
5. Divide the number of points in the noise by the number of points in the pulse width
for the antenna frequency you are using (see table above).
6. To filter out this noise, use a Filter Width equal to or greater than this number.
Vertical Parameters
Filter Width

The width of the running-average window added together in the spatial
trace-differencing filter.
If the filter width is greater than the length of the GPR line, a filter width
equal to the length of the line is used.
The default value is 1 meter.

Type

The shape of the filter used to calculate the running-average trace.
Options are Rectangular, Triangular or Blackman-Nuttall.
The default is rectangular.
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First Break

5.5.1

Edit First Break

Rather than using Repick First Break to determine the First Break Offset (listed in the
Advanced category of the GPR line Acquisition tab, it is sometimes desirable to
calculate or estimate the first break manually and edit the GPR line. This is what the
Edit First Break routine is for.
The first break is edited in a time value in nanoseconds.
One way to calculate the first break offset time is to plot the GPR Line in LineView. Set
the time limit to Minimum to estimate the number of nanoseconds from the top of the
GPR line to the first break.
Edit First Break Parameters
First Break Offset

5.5.2

The time of the first break on the trace.

Repick First Break

Repick First Break is used to re-pick the first break offset for the GPR line (listed in the
Advanced category of the GPR line Acquisition Tab).
When data are collected, the first trace collected is searched to find the first break. This
is the first large deflection (either a positive peak or a negative trough) in the trace and
indicates the arrival of the direct air wave to the receiver.

First
Break
Sometimes the automatic first break search fails and the first break is set to the wrong
value. The Repick First Break routine uses a relative or absolute threshold value to repick the first break for the GPR line.
The relative threshold value is a percentage (0.0 to 100%) of the peak amplitude value in
the trace.
The absolute threshold is a signal amplitude value in milliVolts from -50 to +50.
The first point in the trace to exceed the threshold value is the first break offset time.
This time value can be a decimal number between two points with values on either side
of the threshold.
The default value is 5% or 5 mV. Typical percentages required to get a good first break
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are 5% to 10% or 5 to 10 mV, but if the data are particularly noisy, a higher threshold
may be required.
It is recommended that Repick First break be applied to GPR lines that have not been
Dewowed because the Dewow process introduces a pre-cursor to the data that can
affect the Re-pick process.
Transition defines the first break: a positive deflection, a negative deflection or the first
deflection either positive or negative. The default is both which means the first positive
or negative deflection that exceeds the threshold is the first break.
When determining a threshold value to input, it is a good idea to plot the data in
LineView or Trace Plot and see whether the first major deflection is positive or negative.
If the first deflection is positive, use a positive transition. If the first deflection is negative,
use a negative transition. Repick First Break searches the input traces and records the
first point to exceed the threshold value.
Shift Traces determines if the traces are physically shifted to align with one another. If
Shift Traces is set to No, Repick First Break calculates the first break offset time for each
trace and sets the first break offset to the median value.
If Shift Traces is Yes, each trace is shifted up or down in time to align with the trace with
the smallest first break offset.
Repick First Break may not always give a good pick for the first break. To check the pick,
plot the traces in LineView or Trace Plot and see where the first break is placed on the
GPR line. If not, try another threshold value and see if the pick can be improved. The
threshold needs to be large enough so that the transmit pulse (which should be a higher
amplitude than anything before it) is the point that gets picked.
Usually the first break point on each trace lines up horizontally. However, if data are
collected before the radar system has warmed up properly or if the fiber optic cables (on
some Sensors & Software GPR systems) are damaged, the first break point may drift up
and down from trace to trace. When this problem is visible in the data, the Shift Traces
option can be used to horizontally align all the traces at the threshold value.
It is especially important to set Shift Traces to Yes if further data processing on the GPR
line is required. Many processes like any of the Spatial Filters or the 2D filters use
calculations on amplitude values in adjacent traces. If there is much drift in the data,
these processes may not work as well.
Repick First Break Parameters
Method
Relative Threshold
(% of Peak)

Select the Method used to Repick the First Break: Absolute or Relative.
Percentage of the peak GPR signal amplitude in the trace that defines
the first break.
Values are 0% to +100%.
Default is 5%
Signal amplitude in milliVolts in the trace that defines the first break.

AbsoluteThreshold
Values are -50 to +50 mV.
(mV)
Default is 5 mV
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The trace deflection direction to pick the first break point on.
Options are Positive, to pick the threshold on the first positive part of the
trace that exceeds the threshold, Negative, to pick the threshold on the
first negative part of the trace that exceeds the threshold or Both (first
positive or negative, whichever occurs first in the GPR trace that
exceeds the threshold.
Default is Both.

Shift Traces

Option to permanently shift the re-picked traces so they align
horizontally to the threshold value. Options are Yes to shift traces or No
to just re-pick the first break but not to align the traces.
Default is Yes.
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Gains

Since the radar signal strength normally decreases with increasing time, it is usually
necessary to apply some sort of gain function to boost the weaker signals at later times.
The raw, ungained data shows little signal except for the strong near-surface reflectors
(Figure 24). No gain may be useful in areas where the radar signal is very strong or in
areas where the targets are very shallow.

Figure 24: GPR line with no gain applied.

None of the gain functions are permitted to boost a data point value to greater than + or
– 50 mV. Values where this occurs are trapped and forced to 50 or -50 mV.
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Automatic Gain Control

The Automatic Gain Control (AGC) gain attempts to equalize the amplitudes of all GPR
signals by applying a gain which is inversely proportional to the signal strength (Figure
25). This type of gain is most useful for defining continuity of reflecting events. AGC
does not preserve relative amplitude information, so once AGC has been applied to the
data, you can no longer make reliable deductions concerning the strength of any
particular reflector relative to other reflectors.

Figure 25: GPR line with AGC gain applied with the AGC gain function on the right. AGC applies a gain
inverse to the signal strength. The gain function varies for each trace.

Since the AGC gain is inversely proportional to the signal strength, very small signals
can produce very large gains. To avoid this, a gain-limiting scheme called Maximum
Gain is applied.
AGC Parameters
Window Width:
To calculate the gain to be applied at each point in the trace, AGC locates the average
signal level over a window of width given by Window Width and centered about the
point. The Window Width is specified in units of pulse width based on the antenna center
frequency. In the case of data collected at 100 MHz with a sampling interval of 800 ps,
and a window width of 1.5 pulse widths, 27 points would be used to compute the
average signal strength.
The default of 1.5 is adequate in most cases.
Maximum Gain:
A number between 1 and 32767 can be used to determine the maximum gain that can
be applied to any data point. If the calculated gain value for any point along the trace
exceeds the Maximum Gain value, the Maximum gain value is applied to the data
instead. This maximum gain is fixed for the whole data set.
A typical value would be 50 - 2000 depending on the noise and average signal levels.
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Constant Gain

This routine will apply a constant gain factor to the GPR Line. Only one parameter is
needed, namely the constant factor to multiply all data points by. Thus if the user enters
the number 10, all data points will be multiplied by a factor of 10. This will gain strong
signals and weak signals equally and result in the clipping of strong signals.
The advantages of a constant gain are:



It is easy to understand how the amplification works and,
There is only has one parameter to adjust.

Figure 26: GPR line with a constant gain of 100 applied.

The disadvantage of a constant gain is that it tends to over-gain the strong signals at the
beginning of the trace (Figure 26).
Constant Gain Parameter
Gain:



The constant gain factor that the data set will be multiplied by.
The default value is 100 and typical values for the Constant gain are in the range
from 2 to 1000
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SEC2

The SEC2 (Spreading & Exponential Calibrated Compensation) gain is a composite of a
linear time gain and an exponential time gain. This gain attempts to compensate for the
spherical spreading losses and the exponential ohmic dissipation of energy in the GPR
Line. Since GPR data is attenuated exponentially and the SEC2 is an exponential gain,
it tends to be the gain closest to physical reality. Therefore, unlike the AGC gain, after an
SEC2 gain is applied to a GPR Line, reflections can be compared for relative signal
strength. SEC2 is the preferred gain for GPR data (after applying dewow).

Figure 27: GPR line with an SEC2 gain applied and the SEC2 gain function on the right. This type of gain is
the closest to physical reality because it compensates for the attenuation of the signal with depth.

This gain is essentially an exponential function. This exponential function could, in fact,
go to infinity. Therefore, as with the AGC gain some gain limiting factor must be applied
so a Maximum Gain value is used.
SEC2 Parameters
Attenuation
This quantity represents the radar wave attenuation given in decibels/meter.
The higher the attenuation value, the faster the exponential function rises the more gain
applied at earlier times on the GPR Line. Data collected on low attenuation materials like
sand and hard rock may only require an attenuation of 0 to perhaps 5. Data collected on
high attenuation materials like silts, clay and concrete may require an attenuation of 10
perhaps as high as 40 or 50.
Typical value: 0.5 to 5.

146

EKKO_Project User’s Guide

Processing Functions

Start Value
This is a constant value (or DC) added to the exponential function. The SEC2 gain rises
from this value; normally it will be 1 but for those data sets where more gain is required
at early times, this value can be increased accordingly.
Typical value: 0 to 10
Maximum Gain
This is a number between 1 and 32767 which determines the maximum gain that can be
applied to any data point. When the exponential gain function exceeds the Maximum
gain value, the function levels off at the Maximum Gain value. All points in the GPR trace
later in time are gained by the Maximum Gain value. This maximum gain is fixed for the
whole data set.
Typical value: 50 to 2000.

5.7
5.7.1

Line Editing
Antenna Separation

This is the distance between the transmitting and receiving antennas. For reflection data
this distance is normally kept fixed for every trace collected. Appropriate values of
antenna separation for each antenna frequency are given on the table in the data
acquisition program.
This option is available for editing the antenna separation saved in the data file. It is
important that the correct antenna separation be entered since this value is used in the
computation of the depth axis.
This parameter has no meaning for any mode of operation where the antenna
separation changes (as in a CMP/WARR profile).

5.7.2

Crop Data - Horizontal

Sometimes a GPR Line is too long and needs to be cropped. For example, the ends of a
line may contain poor or uninteresting traces.
Crop Data - Horizontal is used to delete data outside the input minimum and maximum
position.
Crop Data - Horizontal Parameters
Minimum, Maximum Positions
Minimum and Maximum positions of traces are used to retain in the cropped GPR Line.
The Minimum position must be less than the Maximum position. The default values are
the current start and end positions.

5.7.3

Crop Data - Vertical

Sometimes a GPR Line contains too much data in time. For example, if the chosen time
window was too long, the data of interest might occur at early times and the later times
on the GPR line may contain poor, noisy or otherwise useless data.
Crop Data – Vertical is used to delete data outside the input minimum and maximum
time range.
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Crop Data - Vertical Parameters
Minimum, Maximum Times
Minimum and maximum times (in nanoseconds) are used to retain in the cropped GPR
Line. The minimum time must be less than the maximum time. Times can be positive or
negative (data before the first break). If the Start Time is positive, the first break offset is
removed and is recorded in the Acquisition Tab as a negative time.

5.7.4

Pad Data - Horizontal

Sometimes a GPR Line needs to be padded out so two or more lines have exactly the
same start and end positions or number of traces.
Pad Data - Horizontal is used to add data traces from the input minimum position to the
current start position and add data from the current end position to the input maximum
position.
Data traces added to the GPR line have zero (0) amplitude values.
Pad Data - Horizontal Parameters
Minimum, Maximum Positions
Minimum and Maximum positions of the padded GPR Line; the Minimum position must
be less than the maximum position.

5.7.5

Pad Data - Vertical

Sometimes a GPR Line needs to be padded out so two or more lines have exactly the
same minimum and maximum times.
Pad Data - Vertical is used to add data to the top and bottom of a GPR Line; from the
input minimum time to the current start time and/or add data from the current end time to
the input maximum time.
Sample points added to the top of the GPR line have the same amplitude value as the
first sample point while sample points added to the bottom of a GPR Line have the same
amplitude value as the last sample point.
Pad Data - Vertical Parameters
Minimum, Maximum Times
When using minimum and maximum times (in nanoseconds) in the padded GPR Line,
Minimum Time must be smaller than the Maximum Time. To pad the GPR Line on the
top, the input Minimum Time must be less than the current Start Time. To pad the GPR
Line on the bottom, the input Maximum Time must be greater than the current End Time.
Times can be positive or negative (data before the first break).
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Reposition Traces

Before a GPR Line is collected, the Start Position and Step Size are defined. These two
parameters are used to calculate the position of each trace and the end position of the
GPR Line. Often, for a variety of reasons, it is necessary or desirable to change the
trace positions after the survey was run.
For example, a survey run at a step size of 0.5 meters between two survey stakes 100
meters apart should produce 201 traces. However, if the step between traces was
estimated during the survey, the 100 meter stake will likely be encountered before or
after the 201st trace is collected. This means that over the course of the survey the
actual step size was not exactly 0.50 meters, but more like 0.54 or 0.45 meters.
Reposition is used to correct the step size so the GPR Line is the proper length.
Other examples where Reposition Traces may be useful are:



The wrong start position was input so all the traces are in the wrong position.
The wrong step size was input or the odometer calibration was incorrect so all
the traces are in the wrong position.

Reposition would be used in these situations to adjust the trace positions to their actual
position on the GPR line.
Reposition can be used to adjust the trace positions in four different ways (the
Reposition using option determines which):





Input a new Start Position: The Step Size and Length stay the same and the
End Position is adjusted.
Input a new End Position: The Step Size and Length stay the same and the
Start Position is adjusted.
Input a new Step Size: The Start Position stays the same and the Length and
End Position are adjusted.
Input a new GPR line Length: The Start Position stays the same and Step Size
and End Position are adjusted.

Reposition Parameters
The parameters needed for this application are:





Start Position : The Start Position (in meters or feet) of the GPR line.
End Position: The End Position (in meters or feet) of the GPR line.
Length: The length (in meters or feet) of the GPR line.
Step size: The distance between traces (in meters or feet) in the GPR line.

Note: Only one parameter can be changed with each call to this routine so in some
situations it may be necessary to call the routine more than once to modify the trace
positions the way you want.
Example 1
A data file was collected from Start Position of 0.0 and an End Position of 100.0 with a
step size of 0.5. An error was made in that the Start Position should be 10.0. To correct
this, set the Start Position to 10.0. This will adjust all the trace positions with respect to
the new Start Position. The End Position will change to 110.0.
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Example 2
A data file was collected from Start Position of 0.0 and an End Position of 100.0 with a
Step size of 0.5. An error was made in that the End Position should be 120.0. To correct
this, set the Length to 120.0. A new Step size will be calculated to allow the traces to fit
within the set Start (0.0) and end positions (120.0). For example, if the data file contains
201 traces, the new calculated Step size is 120.0/(201-1) = 0.6 meters.
Example 3
A data file was collected from Start Position of 0.0 and an End Position of 100.0 with a
Step size of 0.5. An error was made in that the Start Position should be 10 and the step
size should be 0.25. To correct this, call the routine first and set the Start Position to
10.0. Then call the routine a second time with the Step size set to 0.25. The two calls
will result in a final GPR line that starts at 10.0 and has a step size of 0.25.

5.7.7

Reposition Using GPS

If a GPR line was collected with GPS, every trace has a GPS position saved with it.
Reposition with GPS uses the GPS positions to reposition each trace in the GPR line.
First, using all the GPS positions collected along the GPR line, it calculates the total path
length for the GPR line. Then it divides the distance by the number of traces to compute
a new average step size. The trace number and average step size are then used to
calculate a new position for each trace in the GPR line.
This routine is very useful for data collected in Free Run mode with GPS because lines
collected in Free Run use an estimated step size so the length of the line in the
Acquisition Tab is usually not very accurate. Using GPS provides a good estimate of the
actual length of the line.

5.8
5.8.1

Operations
Amplitude Spectra

Amplitude Spectra uses the Fourier Transform to calculate the amplitude spectrum of
each trace in the GPR line.
The amplitude spectrum is a plot of amplitude versus frequency and consequently
reveals the frequency composition of the trace. This can be extremely useful information
in determining which filter or processing technique would be the most effective in
eliminating noise or emphasizing the desired signal.
Probably the most popular processing stream using Amplitude Spectra is used by the
Average Frequency Spectrum (AFS) routine. Amplitude Spectra is run on the radar
profile to calculate the amplitude spectrum of each trace. Then the average amplitude
spectrum is calculated and displayed. This can be used to decide an appropriate filter to
apply to the profile data.
It is also possible to plot an amplitude spectrum section like a GPR line in LineView to
see how the frequency content varies over the survey line. Note: when plotting
amplitude spectra data in LineView, the frequency is plotted along the Time Axis where
1 ns = 1 MHz. The title of the “Time” axis can be edited to plot “Frequency (MHz)”.
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The plot above displays amplitude spectra data for 100 MHz geological data.

5.8.2

Average Trace

Average trace uses all the traces in the GPR line and calculates the average trace. The
resulting GPR line only contains one trace so it is difficult to plot with LineView but can
be plotted using the Trace Plot.
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The average trace shows signals that are common to all or many traces; for example,
horizontal signals such as the direct air wave, direct ground wave, banding and
reverberations as well as flat reflectors.

5.8.3

Delete Traces

Occasionally, extra traces are recorded in a profile that later need to be deleted. Delete
Traces allows the user to delete a trace at a specific position or many traces in a range
of positions.
After the deletion of the traces, the traces are renumbered and repositioned so the total
length of the line is correct.
Any interpretations attached to traces that are deleted are permanently removed and
cannot be recovered using Undo Process. It is advised that processing routines such as
Delete Traces are applied before adding interpretation.
Delete Traces Parameters
Minimum Position
line.
Maximum Position
GPR line.

Position where first trace is deleted from the GPR
Position where the last trace is deleted from the

To delete one trace at one position: make that position both the Minimum and Maximum
Positions.
Position ranges are independent of the sign of the step size. For example, if step size is
negative, the position range still goes from the minimum position value to the maximum
position value.

The most common usage of Delete Traces is to remove traces collected while the GPR
was stationary in Free Run mode.
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Flip Polarity

Sensors & Software pulseEKKO GPR systems have independent transmitters, receivers
and antennas that can be put in any orientation relative to one another. While collected
data along a profile line, it is important to keep the relative transmitter and receiver
orientation the same, especially after any interruption in data collection to change
batteries, etc.
One way to control polarity is to always have the Sensors & Software or pulseEKKO
name on the electronic units pointed in the direction of antenna movement.
If the transmitter or receiver is rotated 180 degrees and changes the relative orientation,
the signal polarity will reverse. If this happens in the middle of a survey line, negative
signals (troughs) will change to positive signals (peaks) and vice-versa. If this occurs,
the Flip Polarity routine is used to reverse the polarity of all or part of a GPR line.
Flip Polarity is also useful when one wants to merge two profile lines but they have
different signal polarities. Simply reverse the polarity of one of the profile lines and then
use the Merge Lines tool.
Flip Polarity Parameters
Minimum Position Position of the first trace in the GPR line where polarity is
flipped.
Maximum Position Position of the last trace in the GPR line where polarity is
flipped.
To flip the polarity of one trace at one position make that position both the Minimum and
Maximum Position.
Position ranges are independent of the sign of the step size. For example, if step size is
negative, the position range still goes from the minimum position value to the maximum
position value.

The images above show a GPR line where the polarity changes in the middle of the line
(left) and is corrected on the right.
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Insert Traces

The purpose of Insert Traces is to allow blank traces to be inserted at locations which,
for one reason or another, had to be skipped while collecting data out in the field. Adding
blank traces where necessary makes the GPR line the proper length. After inserting
blank traces, the traces are renumbered and repositioned so the total length of the line is
correct.
Note that no matter where and how many blank traces are inserted, the start position of
the GPR line is preserved; inserting traces only causes the end position to change.
Insert Traces Parameters
Minimum Position The position at which to add blank traces in the GPR line.
Number of Traces The number of blank traces to add at the corresponding
position.
Traces are always added in the direction of increasing position; there is always at least
one real GPR trace BEFORE the blank traces.

A GPR line with 10 blank traces inserted in the middle is shown above.
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Mute

Occasionally, a GPR line contains areas of poor data such as noise, a ringing metal
response or a system glitch that draws the eye away from the more important data. Mute
Data is used to mute (zero) a rectangle of data within a GPR line.
Mute Parameters
Minimum Position Position of the first trace in the GPR line to mute.
Maximum Position Position of the last trace in the GPR line to mute.
Position ranges are independent of the sign of the step
size. For example, if step size is negative, the position
range still goes from the minimum position value to the
maximum position value.
Minimum Time

First time in the GPR line to mute.

Maximum Time

Last time in the GPR line to mute.
Minimum time must be less than Maximum Time.

The images above show how the strong ringing from a piece of metal debris (left) was
muted out (right).
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Normal Move-out Correction

The finite separation between the GPR transmitter and receiver results in the top of the
depth scale looking non-linear compared to the rest of the scale. This is because,
especially at shallow depths, the depth to a reflector is not equal to half the signal path
length.
The Normal Move-Out Correction convert a finite offset GPR line to a zero offset
(transmitter and receiver coincident) by correcting for normal move-out using the input
velocity.
This process stretches the signals at the top of the section so the depth scale and time
start at the same point.
Normal Move-out Parameter
Velocity

The average subsurface velocity in meters/nanosecond to use to
correct the signal for the normal move-out.

The images above show the effect of applying the Normal Move-out Correction to 100
MHz geological data.

156

EKKO_Project User’s Guide

5.8.8

Processing Functions

Rectify

Rectify goes through the GPR line and outputs the rectified version of each trace (i.e. the
absolute value of each point in the trace).
The Rectify utility is very useful when one wants to look at the L1-norm of a data set. By
rectifying a data file and then averaging all the traces together one can obtain a very
useful estimate of amplitude fall-off versus time.
Rectifying a trace converts the trace from a wavelet with both positive and negative
components to a wavelet with all positives.
L1 norm (rectify equation):

At a single time or depth value the amplitude value will be the same amplitude as the
raw value but always positive. When amplitude values are averaged over a time or depth
range this will give the average, absolute value.
Rectify Variables: There are no input parameters required for this application.
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Appendix A File Formats
1. Interpretation Reports
The following information is written to the Interpretation Report:



















Header: lists the Interpretation Names and count of observations for each
interpretation
Drawing Tool
Interpretation Name
GPR Line Name
Position along Line (m or ft.)
X Position (m or ft.)
Y Position (if grid data)
Depth (m or ft.)
Time (ns)
Elevation (if available, m or ft.)
Signal Amplitude (millivolts)
Velocity (ft/ns or m/ns): Velocity is used to calculate depth and elevation.
UTM Easting with Zone
UTM Northing with Zone
Latitude (degrees and decimal degrees; + = North, - = South)
Longitude (degrees and decimal degrees; + = East, - = West)
GPS Elevation of the GPS receiver
Comments

In a box interpretation, the positions of the upper-left and bottom-right corners are listed.
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2. Global Positioning Files
The Global Positioning System (GPS) uses special satellites around the Earth to
determine the position of a GPS receiver located at any position on the surface of the
Earth. GPS receivers can be purchased from a number of manufacturers.
Sensors & Software GPR systems have a serial port for attaching a GPS receiver to
record the position of the GPR unit. This port will accommodate any GPS receiver that
has a standard serial port output.
The GPS receiver sends one or more types of data strings to the GPR. These strings,
called NMEA-0183 strings, contain positional and other information in specific formats.
Each type of string is specified by a 5-character prefix. There are numerous NMEA
strings but to integrate the GPS data into the GPR data, the GPS receiver must be
sending the GPGGA string. This may require reprogramming the GPS receiver; most
systems come with PC-based utility software.

3. GPS
The .GPS file format consists of a line listing the GPR trace number and the position
based on the odometer and the step size, followed by one or more NMEA strings. The
GPGGA string must be included in this list.
Depending on the version of the embedded data acquisition software, the trace number
lines may have every trace, every nth trace or a somewhat random interval between
trace numbers.
Trace #2 at position 0.050000
$GPGGA,185721.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,-35.1,M,,138*68
$GPGSA,A,3,15,05,18,21,26,29,51,02,08,,,,2.3,1.2,1.9*32
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D
Trace #3 at position 0.100000
$GPGGA,185731.00,4337.9926,N,07938.2534,W,2,09,1.2,110.3,M,-35.1,M,,138*6F
$GPGSA,A,3,26,18,05,21,15,29,08,02,51,,,,2.3,1.2,1.9*32
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D
Trace #4 at position 0.150000
$GPGGA,185732.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,,138*6B
$GPGSA,A,3,21,15,26,29,18,05,51,02,08,,,,2.3,1.2,1.9*32
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D
Trace #5 at position 0.200000
$GPGGA,185733.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,,138*6A
$GPGSA,A,3,21,51,26,29,15,18,05,02,08,,,,2.3,1.2,1.9*32
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D
Trace #8 at position 0.350000
$GPGGA,185734.00,4337.9926,N,07938.2534,W,2,09,1.2,110.4,M,-35.1,M,1,138*5C
$GPGSA,A,3,21,15,26,29,51,18,05,02,08,,,,2.3,1.2,1.9*32
$GPVTG,0.0,T,,,0.0,N,0.0,K*2D
Trace #12 at position 0.550000
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4. GP2
The .GP2 file format consists of 5 header lines, then a line that defines the parameters
listed on each line for the rest of the file:
Trace number
Number of odometer ticks
GPR line position (based on odometer ticks, odometer calibration value and step size)
Time elapsed in seconds since the start of the data collection
GPS NMEA string in quotes
Any NMEA strings output by the GPS receiver are listed. The GPGGA string is required
to be in the list.
;GPS@@@
;Ver=1.1.0
;DIP=2009-00152-00
;Date=2012-Jan-09 13:56:16.0
;--------------------------------------------traces,odo_tick,pos(m),time_elapsed(s),GPS
1,0,0.000,0.00,"$GPGGA,185713.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*69"
1,0,0.000,0.00,"$GPGSA,A,3,15,21,29,51,26,18,08,02,05,,,,2.3,1.2,1.9*32"
1,0,0.000,0.00,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,1,0.001,0.60,"$GPGGA,185714.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*6E"
1,1,0.001,0.60,"$GPGSA,A,3,15,29,21,26,18,05,08,02,51,,,,2.3,1.2,1.9*32"
1,1,0.001,0.60,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,3,0.003,1.59,"$GPGGA,185715.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*6F"
1,3,0.003,1.59,"$GPGSA,A,3,18,21,05,26,29,15,08,02,51,,,,2.3,1.2,1.9*32"
1,3,0.003,1.59,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,2,0.002,2.58,"$GPGGA,185716.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,1,138*5D"
1,2,0.002,2.58,"$GPGSA,A,3,05,21,15,18,26,29,08,02,51,,,,2.3,1.2,1.9*32"
1,2,0.002,2.58,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,3,0.003,3.63,"$GPGGA,185717.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,2,138*5F"
1,3,0.003,3.63,"$GPGSA,A,3,21,26,15,29,18,05,08,02,51,,,,2.3,1.2,1.9*32"
1,3,0.003,3.63,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,5,0.005,4.61,"$GPGGA,185718.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,3,138*51"
1,5,0.005,4.61,"$GPGSA,A,3,18,21,26,29,05,15,08,02,51,,,,2.3,1.2,1.9*32"
1,5,0.005,4.61,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,6,0.006,5.60,"$GPGGA,185719.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*63"
1,6,0.006,5.60,"$GPGSA,A,3,21,18,15,05,29,26,08,02,51,,,,2.3,1.2,1.9*32"
1,6,0.006,5.60,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,10,0.009,6.59,"$GPGGA,185720.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*69"
1,10,0.009,6.59,"$GPGSA,A,3,18,21,15,05,26,29,08,02,51,,,,2.3,1.2,1.9*32"
1,10,0.009,6.59,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"
1,20,0.019,7.58,"$GPGGA,185721.00,4337.9926,N,07938.2533,W,2,09,1.2,110.2,M,35.1,M,,138*68"

161

EKKO_Project User’s Guide

Processing Functions

1,20,0.019,7.58,"$GPGSA,A,3,15,05,18,21,26,29,51,02,08,,,,2.3,1.2,1.9*32"
1,20,0.019,7.58,"$GPVTG,0.0,T,,,0.0,N,0.0,K*2D"

The last characters (before the quote symbol) in the NMEA string is the checksum. The
checksum is the xor of each byte between the $ and *. NMEA lines with a failed
checksum are assumed to be corrupt and not recorded.

5. SEG-Y
The following describes in detail which variables are loaded in the SEG-Y conversion
program.
Reel Identification Header - ASCII Portion
The reel identification header is first loaded with the GPR header file (*.HD).
This file is copied directly into the ASCII portion.
Reel Identification Header - Binary Portion
The following lists the variables used in the binary portion.
Bytes
3201-3204
3205-3208
3209-3212
3213-3214
Set to # of
3215-3216
3217-3218
3219-3220
3221-3222
3223-3224
3225-3226
3227-3228
3229-3230
3231-3250
3251-3252
3253-3254
3255-3256
3257-3258
3259-3260
3261-3600

Description
Set to zero.
Set to zero.
Set to zero.
Set to one for REFLECTION data.
offsets for CDP data.
Set to zero.
Sample interval down trace in psec.
Sample interval down trace in psec.
Number of points in trace.
Number of points in trace.
Set to three (fixed point 2 bytes).
CDP fold. Set to zero for REFLECTION data. Set to # offsets for
CDP data.
Trace Sorting Code. Set to three for single fold data. Set to one for
multifold data.
Not used.
Set to two (no binary gain recovery).
Set to one (no amplitude recovery method).
Set to 1 or 2 depending on units used.
Not used.
Not used.
Not used or NON STANDARD (see the following).

Non-Standard
Bytes Description
3261-3262
Number of traces (I*2)
3401-3410
Job number (CHAR*10)
3411-3480
Title 1 (CHAR*70)
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3571-3572
3573-3574
3575-3594
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3599-3600
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Title 2 (CHAR*70)
Date (CHAR*20)
Number of stacks (I*2)
Pulser voltage (I*2)
Survey mode (CHAR*20)
Frequency (R*4)
Dewow (I*2) (0-NOT DONE 1-DONE)

The following lists the variables used in the binary portion.
Bytes

Description

1-4
5-8
9-12
13-16
17-20
21-24
25-28
29-30
31-32
33-34
35-36
37-40
41-44
45-48
49-68
69-70
71-72
73-76
77-80
81-84
85-88
89-104
105-106
107-114
115-116
117-118
119-120
121-240

Trace number from 1 to number of traces.
Trace number from 1 to number of traces.
Tape record number 1 to number of traces.
Set to one.
Not used.
CDP ensemble number.
Trace # within CDP. (one for REFLECTION data)
Set to one.
Set to one.
Set to one.
Set to one.
Antenna sep. times 1000. (Not official SEG-Y format)
Receiver Elevation data times 1000.
Transmitter Elevation data times 1000.
Set to zero.
Set to -1000.
Set to -1000.
Transmitter x-coord times 1000.
Transmitter y-coord (set to zero).
Receiver x-coord times 1000.
Receiver y-coord (set to zero).
Not used.
Timezero in ns.
Not used.
Number of points in trace.
Sample interval in psec.
Set to one.
Not used.
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6. Topography Files







Each line of text must contain a pair of numbers representing position along the GPR
line and elevation.
These numbers can be separated by a space or a tab.
The range of topographic information does not have to correspond exactly to the
range of positions in the GPR line. Positions lying outside the range of available
topographic data will be assigned to the elevation of the nearest endpoint.
Since linear interpolation is used to obtain the elevation at each trace position it is
not necessary to have an elevation for every trace in the file. Topographic data can
be added to a GPR line with as little as two position and elevation pairs (in the case
of a constant slope). The more data points entered, the more detail there will be in
the topographic correction.
Topographic files must have a .top extension.
0.0

935.8

10.1

933.9

22.7

930.3

30.5

932.7

34.6

936.5

Topography files are text files that are easily created using Windows Notepad, which
defaults to a .txt file extension
To change the Notepad default to a .top extension:
1. In Notepad click File > Save As.
2. In the Save as dialog box in the Save as type drop-down list, click All Files.
3. In the File name text box, typing file name and append it with the .top extension.
For example, Line87.top.
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Appendix B Calculating GPS Latency
1. Choose a large outdoor area with a clear view of the sky, like a parking lot.
2. In the center of the area, place a metallic disk, roughly 1 ft in diameter. You can
use a foil covered piece of cardboard. It is advised that the disk be taped down
so that it does not move.
3. Set up your GPR to collect GPS data as well. Make sure that the GPS is
centered directly over top of the GPR unit (as shown below).
4. Set GPR recording Depth to 0.50m (10.1ns) so that data can be collected quickly
without skipping traces.
5. Start a new line and collect data running over the disk in a flower pattern (see
figure below). Try to run over the disk in as many different directions and as
many different speeds as you can. The faster the data are collected over the
plate, the more accurate the latency value will be.
*Make sure no traces are skipped.

6. Export the GPZ data from the flash memory card and open it in the
EKKO_Project software. MapView should display your GPS path like this:
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7. Double click the line name in the Project Explorer to open in LineView. Each time
you ran over the disk you should see a disturbance in the direct wave like this:
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8. Create a new Point type interpretation.
Note: If the Interpretation module is not enabled, use the mouse cursor and
the F8 key for steps 8 to 13. Pressing the F8 key with the mouse cursor on
the disk response in the GPR line saves the position information to the
Clipboard. Copy the position information of each disturbance to a csv file.

9. Scroll through the line and enter and add an observation at the center of each of
the disturbances. The vertical placement of the observation is not important.
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10. Close LineView. Now you should see all of the observations clustered near the
center of the flower pattern in MapView.

11. Run the Project Report under File > Report > Project Report, make a new
folder called 0s_latency and save the report inside.
12. Go to Tools > GPS > Latency and set it to 1 second, click OK.
13. Run the Project Report again under File > Report > Project Report, make a
new folder called 1s_latency and save the report inside.
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14. Open a new spreadsheet in Excel. Copy and paste the UTM coordinates from
the two project reports into the columns of the new spreadsheet.
0s Latency Set

1s Latency Set

Easting

Northing

Easting

609895.67

4831925.06

609895.1

4831924.38

609895.55

4831924.67

609895.69

4831926.31

609895.36

4831925.25

609897.68

4831923.17

609896.07

4831924.94

609892.26

4831924.66

609895.51

4831924.85

609896.8

4831925.95

609895.65

4831925.42

609896.04

4831922.3

609895.77

4831924.83

609894.77

4831925.44

609895.1

4831925.07

609899.3

4831925.17

Northing

15. In the column to the right, calculate the speed in each axis by differencing the
Eastings and the Northings. So Speed in Easting is Easting at 0s latency –
Easting at 1s latency
0s Latency Set

1s Latency Set

Speed

Easting

Northing

Easting

Easting

609895.67

4831925.06

609895.1

4831924.38

0.57

0.68

609895.55

4831924.67

609895.69

4831926.31

-0.14

-1.64

609895.36

4831925.25

609897.68

4831923.17

-2.32

2.08

609896.07

4831924.94

609892.26

4831924.66

3.81

0.28

609895.51

4831924.85

609896.8

4831925.95

-1.29

-1.1

609895.65

4831925.42

609896.04

4831922.3

-0.39

3.12

609895.77

4831924.83

609894.77

4831925.44

1

-0.61

609895.1

4831925.07

609899.3

4831925.17

-4.2

-0.1

Northing

Northing

16. In the next two columns calculate a corrected Easting and Northing based on
some defined latency value. So the Corrected Easting is Easting at 0s latency –
Speed_Easting * Latency_s (0s,1s)
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17. Calculate the standard deviation of each of the corrected axes (Easting and
Northing) and then calculate the average standard deviation:
0s Latency Set
Easting

1s Latency Set
Northing

Easting

Speed
Northing

Latency

Easting

Northing

0
Corrected
Northing

Corrected Easting

609895.67

4831925.06

609895.1

4831924.38

0.57

0.68

609895.67

4831925.06

609895.55

4831924.67

609895.69

4831926.31

-0.14

-1.64

609895.55

4831924.67

609895.36

4831925.25

609897.68

4831923.17

-2.32

2.08

609895.36

4831925.25

609896.07

4831924.94

609892.26

4831924.66

3.81

0.28

609896.07

4831924.94

609895.51

4831924.85

609896.8

4831925.95

-1.29

-1.1

609895.51

4831924.85

609895.65

4831925.42

609896.04

4831922.3

-0.39

3.12

609895.65

4831925.42

609895.77

4831924.83

609894.77

4831925.44

1

-0.61

609895.77

4831924.83

609895.1

4831925.07

609899.3

4831925.17

-4.2

-0.1

609895.1

4831925.07

Standard Deviation:

0.286256628

Avg Standard Deviation:

0.242100186

0.264178407

18. Now adjust the Latency value (in red) to minimize the Avg Standard Deviation
0s Latency Set
Easting

1s Latency Set
Northing

Easting

Speed
Northing

Latency

Easting

Northing

Corrected
Easting

0.125
Corrected
Northing

609895.67

4831925.06

609895.1

4831924.38

0.57

0.68

609895.5988

4831924.975

609895.55

4831924.67

609895.69

4831926.31

-0.14

-1.64

609895.5675

4831924.875

609895.36

4831925.25

609897.68

4831923.17

-2.32

2.08

609895.65

4831924.99

609896.07

4831924.94

609892.26

4831924.66

3.81

0.28

609895.5938

4831924.905

609895.51

4831924.85

609896.8

4831925.95

-1.29

-1.1

609895.6713

4831924.988

609895.65

4831925.42

609896.04

4831922.3

-0.39

3.12

609895.6988

4831925.03

609895.77

4831924.83

609894.77

4831925.44

1

-0.61

609895.645

4831924.906

609895.1

4831925.07

609899.3

4831925.17

-4.2

-0.1

609895.625

4831925.083

Standard Deviation:
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Avg Standard Deviation:

0.056759662

19. Once you have found the minimum Average Standard Deviation, this is the
latency value to use for this GPS unit.
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Appendix C Glossary
1. Definitions
Term
Attenuation

Description
Represents the radar wave attenuation given in decibels/meter.
The higher the attenuation value, the faster the exponential function
rises the more gain applied at earlier times on the GPR Line.

Attributes

Characteristics derived from original data. Examples are the average
amplitude of the dominant frequency between two times or depths.

Automatic Gain Control
(AGC)

The Automatic Gain Control (AGC) gain attempts to equalize the
amplitudes of all GPR signals by applying a gain which is inversely
proportional to the signal strength.
This type of gain is most useful for defining continuity of reflecting
events.

Average Frequency
Spectrum (AFS)

Use AFS plots to determine the frequency of a signal on which to
base processing and filtering, similar to band-pass.

Average Trace
Amplitude (ATA)

The Average Trace Amplitude (ATA) plot displays the average signal
amplitudes (in microvolts) for an entire data file.
This plot is a good way to display how rapidly the signal amplitude
decays to the background level, giving you an idea of the maximum
penetration for the data file.

Background Average
Subtraction (BAS)

Use BAS to subtract the average trace of the entire GPR line from
every trace in the line.
This process enhances dipping events (such as hyperbolas from
point targets) and removes horizontal responses common to all
traces in the line. It is also used to remove the direct air and direct
ground waves (transmit pulse) visible at the top of the line. BAS also
removes horizontal bands in the data present throughout the length
of the line.

Background Subtraction

Use Background Subtraction to apply a running-average background
subtraction to the data set. This process enhances dipping events
(such as hyperbolas from point targets) and suppresses or
completely removes horizontal responses. This can be very useful
for removing localized flat-lying events.

Bandpass Filter

Use bandpass filtering when the GPR signal is contained in a
defined band of frequencies and there is "noise" energy in the
remainder of the spectrum. Applying bandpass filtering enhances
the desired signals at the expense of the out-of-band noise
(Dewow).
Bandpass is based on Fourier transform filtering concepts.

Dewow

The process of removing a very low frequency component from GPR
data. These low frequency data components are associated with
either inductive phenomena or possible instrumentation dynamic
range limitations.
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Term

Description

DynaQ

DynaQ is an advanced, patented technology that dynamically
adjusts stacking as system speed varies. In most situations, moving
the system at a comfortable speed stacks enough to generate good
quality data.

Enveloping

Enveloping converts a trace from a wavelet with both positive and
negative components to a monopulse wavelet with all positive
components.
The process removes the oscillatory nature of the radar wavelet and
shows the data in its true resolution. Enveloping can also simplify
radar section display making it easier to interpret.

Filter Type

Dictates the weighting the traces on the edges of the Filter Width
have on the average trace calculation.

First Break Offset

The number of nanoseconds from the start of the trace to the first
break.

GPS Files

Attaching a GPS file adds Latitude and Longitude, UTM coordinates,
and GPS elevation to every trace in the GPR line.
A GPS file is created by attaching a GPS system to the GPR system
during data collection. GPS files contain lines of standard GPS
positional output text (called NMEA strings) and the associated GPR
trace number. When the GPS file is attached, latitude, longitude, and
GPS elevations for every GPR trace are saved into the GPR file.

GPZ Files

Compressed files containing GPR lineset and grid data

Grid

A square or rectilinear set of straight lines which cover an area.
Acquiring data on a grid means acquiring data along each line
forming the grid.
Acquiring data on a grid is a pre-requisite for creating depth or time
slice images. Conventional notation is to use a Cartesian coordinate
system with X and Y axes.

Highpass Filter

Removes frequencies below a cut-off frequency. Used for removing
low frequency content in the GPR data; sometimes used instead of
the Dewow filter.
High Pass is a recursive filter designed for filtering GPR lines in the
time domain. It is an infinite impulse response zero phase filter.

Interpretation Module

Interpretation module in LineView to create interpretations of Points,
Polylines, Boxes, and Annotations, view them in GPR lines, and
then output the interpretational information in reports.

KMZ Files

The KMZ files generated by a Noggin contain GPS information
describing the path travelled during line collection.
These files can be configured to display depth measurements along
the line, making the data easier to interpret. Noggin enables you to
export KMZ files which can be opened in Google Earth.

Lineset

All GPR lines in a project contained in one folder; collections of GPR
lines that may or may not be related to one another.
Linesets can be edited to add or delete GPR lines. GPR lines in
linesets can also be cut and/or copied and pasted into other linesets.
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Term

Description

LineView

Shows GPR line data cross sections. Uses EKKO_View/Interp
application modified to work with and get launched from
EKKO_Project.

Lowpass Filter

Removes frequencies above a cut-off frequency - useful for
removing high frequency noise in GPR data.
Low pass is a recursive filter designed for filtering GPR lines in the
time domain. It is an infinite impulse response zero phase filter.

Migration

The migration process applies a synthetic aperture image
reconstruction process to the GPR line.

nanosecond

A nanosecond is 10 seconds (one billionth of a second).

Overlap

Overlap (% of slice thickness) between the adjacent depth/time
slices.

picosecond

A picosecond is 10

Polylines

A polyline is a list of points, where line segments are drawn between
consecutive points.

Polyline Output Interval

The horizontal distance (meters or feet) between points on any
polylines in the project. To interpolate and list more points than just
the input observation points, enter them text box. A common interval
is the step size for the GPR line

Project Explorer

The Project Explorer is similar to Windows Explorer, which lists
folders and files. In Project Explorer, grids and linesets are used just
like folders in Windows, and GPR lines are similar to Window
Explorer files.

Processing Module

The optional Processing module allows you to edit and process
data, including cropping data, time filters, migration and gain.
Popular processing streams can be saved as Recipes and applied to
other GPR projects.

Properties Window

Displays details of each GPR line including acquisition parameters
and associated files

Slice

Describes the GPR data in a depth slice when the data is displayed
as a computer generated image. Normally shortened to slice.

SliceView
(EKKO_Mapper)

SliceView creates and displays GPR depth slice maps quickly and
easily. Using the systematic grid data acquisition process common
to pulseEKKO PRO, Noggin, or Conquest systems, images at
multiple depths are generated in minutes.

Spatial Filter

Spatial filters act on radar data in the spatial (or positional) direction.
These filters use adjacent traces during the filtering procedure and
alter the shape of the trace through various mathematical
manipulations designed to enhance or eliminate certain features.

Spreading &
Exponential Calibrated
Compensation (SEC2)

SEC2 gain is a composite of a linear time gain and an exponential
time gain which attempts to compensate for the spherical spreading
losses and the exponential ohmic dissipation of energy in the GPR
Line.

-9
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Term

Description

Time Window

The maximum time selected for viewing, processing or data
acquisition along a line. The length of the time window in
nanoseconds (ns).

Time Sampling Interval

The time in picoseconds at which the GPR signal is sampled. Often
set automatically by the system based on GPR frequency.

Topography Files

A topography file is a text file containing GPR line positions and the
elevations at those positions. When a topography file is attached to
a GPR line, elevations for every GPR position are saved into the
elevation field of the GPR trace header.

Trace Plot

View Traces when you want to display subtle features in the data file
or view the effect of different editing and processing types have on
individual traces.
Viewing traces can help you determine whether time-zero point
needs to be edited. Normally the time-zero point should occur at the
first large deflection in the signal. If not, time scales and depth
scales on section plots will be inaccurate.

Universal Transverse
Mercator (UTM)

UTM is a geographic coordinate system that uses a 2-dimensional
Cartesian coordinate system to give locations on the surface of the
Earth. It is a horizontal position representation, i.e. it is used to
identify locations on the Earth independently of vertical position, but
differs from the traditional method of latitude and longitude in several
respects.

UTM Zone

The UTM system divides the Earth between 80°S and 84°N latitude
into 60 zones, each 6° of longitude in width.

UTM Zone Number

Zone 1 covers longitude 180° to 174° W; zone numbering increases
eastward to zone 60 that covers longitude 174 to 180 East.

UTM Letter

Each zone is segmented into 20 latitude bands. Each latitude band
is 8 degrees high, and is lettered starting from "C" at 80°S,
increasing up the English alphabet until "X", omitting the letters "I"
and "O" (because of their similarity to the numerals one and zero).
The last latitude band, "X", is extended an extra 4 degrees, so it
ends at 84°N latitude, thus covering the northernmost land on Earth.
Latitude bands "A" and "B" do exist, as do bands "Y" and "Z". They
cover the western and eastern sides of the Antarctic and Arctic
regions respectively.

Velocity

Speed at which GPR signals travel. Velocity is a critical parameter
when creating depth slice images and estimating target depth since
velocity is used to convert travel-time to depth.

Vertical Filter

Applies a running average filter vertically (down the trace) to a GPR
line. The signal is averaged by replacing the data value at a given
point by the average data value over a window centered about that
point. Its primary purpose is to reduce random or high frequency
noise by acting as a low pass temporal filter.
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2. Abbreviations
Abbreviation

Full Phrase

AFS

Average Frequency Spectrum

ATA

Average Trace Amplitude

AGC

Automatic Gain Control

BAS

Background Average Subtraction

GPR

Ground Penetrating Radar

GPZ

GPR Project Zip file

MAPI

Messaging Application Programming Interface

MHz

Megahertz

ns

nanoseconds

ps

picoseconds

SEC2

Spreading & Exponential Calibrated Compensation

UTM

Universal Transverse Mercator
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